Zorin Lite: Rhythmbox not closing when I click exit button

While audio is playing, I click the exit button at top right of the Rhythmbox window. The program disappears (and there is no system tray icon either) but the audio continues. I have to find the Rhythmbox process in the task manager and kill it to stop the audio.

Screenshot of Rhythmbox process continuing even after I clicked exit

However if I stop playback of audio before I click exit, the Rhythmbox process disappears by itself.

Any fix for this?

PS There used to be a similar problem for VLC (click exit at end of playback but wouldn't be able to open a new file until I opened the task manager and killed a process either with "vlc" in the name, or with the VLC icon next to it). However now that I wanted to post about it, the VLC issue seems fixed. But Rhythmbox issue ongoing.

1 Like

This is why I use Audacious or Exaile and why I stopped using Gnome-Rhythmbox. Exact same issue and reporting the bug got the bug closed.

1 Like

I use Rhythmbox with a library of over 28000 songs and has worked amazing for me.

YMMV but I feel like it's less the app that's an issue and more like a pulseaudio flaw. I have had issues with that, before, with static and other problems.

1 Like

This looks intentional, I have Zorin Core and closing Rhythmbox just closes its window letting the actual audio track playing in background. You can easily stop it by clicking on date and time tray, hover over the playing audio track container and click πŸ—™. Note that you may see 2 containers, the first one is to play previous audio track, pause audio track and play next audio track while the second one is to reopen Rhythmbox or close the audio track.

Can you please tell me the issues you had?

1 Like

The biggest issue was when i booted or rebooted it would cause a loud screeching sound through my headphone port (I keep my system plugged into a surround sound system) that would be ear-piercingly loud.

Also had issues with latency, at times.

Finally, I would just lose audio completely.

Note: These issues happened on different distros.

1 Like

Really interesting, I have the same, sometimes audio tracks are much distorted and with a screechy sound. This is really rare, though, because I play my audio tracks infrequently and then because it seems to happen mostly when I run multiple software altogether, so it's understandable. Audio loss instead happens to me often when I reopen the laptop lid after much time or with applications running, but pulseaudio -k command to restart audio service is a great workaround. The last weirdest issue I had on Rhythmbox was that after playing some audio tracks it plays some of them in few seconds (despite they last minutes) with sound muted, so all I see is the ball on audio tracks time bar running from left to right really fast for some audio tracks, then all returns normal.

i love vlc , so i removed rhythmobx and use vlc instead of it.
but if u want to solve that problem , there is solution for that, i have tried it and worked very well. u need to install plugin for rhythmbox it's name is close on hide and that will solve the problem.


I use Zorin OS Lite, so this may be why what Luca_Paven said did not work for me before.

1 Like

You can easily stop it by clicking on date and time tray, hover over the playing audio track container and click πŸ—™. Note that you may see 2 containers, the first one is to play previous audio track, pause audio track and play next audio track while the second one is to reopen Rhythmbox or close the audio track.
In Zorin Lite (XFCE):

  • Clicking on the time in the system tray just brings up a small calendar.
  • Clicking on the volume icon brings up a long list of every single audio app installed with accompanying control buttons... including Rhythmbox (although not by its name, instead by the name of the file it's playing), and a "Choose playlist" option. There I can pause the audio. But no "X" to close Rhythmbox... I try things until a right-click brings the Rhythmbox window back up. Yay! Now, if I remember to press Pause first, I can finally close Rhythmbox.

I certainly won't be making any attempts to teach my mum all this rigmarole. Bye-bye Rhythmbox, hello some other audio player, hopefully one where "close means close".

I'll give Audacious and Exaile a try over the next few days.

And thanks @Luca_Pavan , @Aravisian for clearing up this issue. At least now I know how to stop Rhythmbox (and perhaps other similarly-(mis)behaving apps in future) without having to fire up the task manager.


The last week or so, there have been occasional problems with scratchy sound when I start playing audio, or video with audio, in various programs (e.g. VLC, IPTVnator, web radio in Chrome).
Sometimes the audio gets better after 30-60 seconds. Sometimes it doesn't, but I notice that so far, it has only happened when I have WeChat in Wine running, and the scratchiness stops when I close WeChat.

1 Like

In my case it lasts few seconds, usually fewer than 10, possibly 5.

Yeah, me, too, looks happening when running much β€œheavy” stuff in the same moment, or a CPU usage peak.

1 Like

I read, replied and marked as solution another answer before I saw yours.

This might be useful to some people, but as I see nothing to download (releases: 0; other links lead to webpages, not files; no instructions on that page itself, nor links to other sites that might have instructions or general info on how to use plug-ins), it seems as user-unfriendly as Rhythmbox itself.

Also, in my stubborn opinion :grin: , I did not click hide. I clicked close, and if Rhythmbox developers have chosen to abuse decades of GUI convention and map the close button to some other action (like Microsoft mapping the close button to "yes, please go ahead and install the latest version of Windows even though I specifically did not press the Accept/Install button"), I am not going to go out of my way to learn how to compile and install Rhythmbox python plug-ins to work around their abuse of the close button. I will work around their abuse of the close button by simply installing a different program that doesn't abuse the close button.

(Yes, software where the close button does not close the program is a pet peeve of mine. :grin: But at least most of them have the sense to leave some kind of sign, like a button in the task bar/panel or icon in the system tray, that you can see and interact with.)

But thanks anyways, and hopefully that plug-in works for people who know how to use it.


it seem that the version of Rhythmbox that used in zorin is old, i removed it and install Rhythmbox from flatback, and i found that problem solved by default in it.
sudo apt remove rhythmbox

flatpack install https://dl.flathub.org/repo/appstream/org.gnome.Rhythmbox3.flatpakref


Yes, I see Zorin is using older versions, why not using the newest that have all the fixes?

Good to hear that there's a solution for those willing and able to use a Flatpack version. Personally, as a couple of the computers I have installed/will install Zorin Lite on are quite old and underpowered, I am trying to avoid the additional overhead of Flatpack and Snap apps as much as possible.

i don't know, but i think when u run that command in terminal in zorin(which is based on ubuntu 20.04)
sudo apt install rhythmbox it install and use the version of rhythmox which available in the Ubuntu 20.04 repository. This version is specifically built and tested for compatibility with the Ubuntu 20.04 system.
when zorin be based on(ubuntu 22.04) that command will install the new version. i think all about compatibility and dependences and libraries. so to get the new version of apps i think u install it from snap and flatpak


that app( rhythmox not imporant for most of us, we can use alternative is better) so no problem.

i wish zorin be based on ubuntu 22.04 to avoid that

That is the trade-off with a Long-Term Support distro: stability vs latest apps.

1 Like

The ZorinGroup will often include a later version if that later version is shown stable.
Or even if it gives a better chance for users. We all know the examples of the much higher kernel. And Zorin OS 16 Lite included XFCE 4.16 out of the gate.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.