Zorin Lite - Scaling x2 issues on buttons and apps


I am running 15.3 lite and I am scaling x2 but some windows have buttons which are still small (for example volume control).
Some QT based apps do not scale at all for example VLC. I tried to set QT_SCALE_FACTOR to 2 but the app does not start at all with that variable set. Zoom instead with the same variable set scales ok except the windows buttons which stay small. Is this expected?


QT based apps- you gave me a clue for another thread dealing with wrong sized icons. Thanks for helping out.
What is your normal screen resolution?

Thank you!

See QT Docs for reference.

3840x2160 60Hz.
I have been having the same issue with windows buttons on another Xfce based distro (except that VLC was working OK), I just wondered if this came up for Zorin.

me@Odyssey:~$ export QT_SCALE_FACTOR=2
milasx@Odyssey:~$ vlc
VLC media player 3.0.8 Vetinari (revision 3.0.8-0-gf350b6b5a7)
[00005605a0a26570] main libvlc: Running vlc with the default interface. Use ‘cvlc’ to use vlc without interface.
Gdk-Message: 19:01:45.816: vlc: Fatal IO error 0 (Success) on X server :0.0.

Just to confirm some of the Xfce windows have also buttons that do not scale, for example the panel configuration window. Any ideas of how to fix it?

Can you see if the last post in the above thread helps you?
When using the scale factor, I would place it in ~.profile as export, rather than entering it into terminal

Thank you - it does not help. I read on another forum that the issue is that there are no icons available for the x2 size hence VLC does not start. I am not sure where the icons come from as VLC does scales up in another distros that I use.

With respect to buttons and other apps I followed these guidelines and everything works OK except VLC and apart from the fact that in order to have the correct size of buttons in system windows I have to use the Default-xhdpi window manager which looks a bit buggy.

What happens if you try changing icon themes?

It works with the Gnome icons :slight_smile:

Obviously the Zorin icons are better but now we know :slight_smile:

The remaining question is the Windows Manager when you get a minute.


Ok, then what we may need to look at is the scaling perameters of the Zorin Icon theme.
As you are using Zorin Lite, you can enter into terminal

pkexec thunar

This will prompt for password, then open an elevated privilege Thunar. The third button over from the far left side of the toolbutton is an Up Arrow. Whack that once or twice.
You should now be seeing the topmost level of Root, including the directory /usr
Open that, then /share, then /icons
From here, I would do a split screen if one monitor, or one open window on each monitor, but- You want to navigate to Zorin icons and to Gnome icons. In each directory, you will find index.theme
Open those for each and compare the Directory list and the scaling list.
Scroll down to where you see Directory List. Look for typoes or Missing Entries in the directory list, comparing against the Gnome (Known working) index.theme Directory List.
If all is well, scroll down to where you see


Check that size and minsize are as shown above, for each of the Scalable Sections.

Sure thing.

I had MinSize=16


Changing it to 8 did not seem to fix the issue.

Also another difference is that in the directory for Zorin I have directories like this
32x32 and 32x32@2x (for each size) while in gnome the @2x are missing.

That is normal- it is just a different method of organizing the theme.

You might just try throwing a PM to zorink or azorin on here and asking, as the Zorin Icon theme is something specific to Zorin Desktop.

Also, what was that about Window Manger?

I also spotted that in the Zorin theme the 256 definition appear to be missing:

The above is in Gnome but not Zorin.

For the window manager see borders in the screenshot above.

Many thanks!

Wow. What XFWM4 theme are you using?

In the meantime… Depending on the theme, you may be able to resize the image files where necessary.
Or, you can open Window Manager Tweaks and try setting DPI to around 220.

Alternatively to both… and this may affect the icon issue, as well… You might try xrandr scaling, instead of using hiDPI.
I am not sure how to do it as I have never done it, but searching for a guide, now.

Ok- guide: In reading it you will learn that Rex is in danger of being kissed by Matt.

Thank you!
I tried xrandr scaling which I worked out that it can be done out of the box with this command:
xrandr --output HDMI-1 --mode 3840x2160 --scale 0.8x0.8
After testing that I actually decided to simply drop my resolution to avoid the blurriness and the performance hit caused by the scaling.
Thank you for helping!!!