Zorin logs me out when I open some apps

Whenever I try to open apps I got from "software" zorin logs me out insted of opening the app , by log out I mean it closes all the opened apps and asks for the password . I have switched from ubuntu to zorin recently and I've had that problem ever since . Is there any other information you need to help me please ?

Are you using Nvidia Graphics? This sounds similar to when Nouveau graphics drivers crash - you get logged out.

Yes , I do .
What can I do to solver that ?

Which Nvidia driver are you using?
Have you added any Grub Parameters?
Can you relay the results of

sudo lshw -C video

description: VGA compatible controller
product: Haswell-ULT Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 0b
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:48 memory:b5000000-b53fffff memory:c0000000-cfffffff ioport:6000(size=64) memory:c0000-dffff
description: 3D controller
product: GM108M [GeForce 840M]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:0a:00.0
version: a2
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:52 memory:b3000000-b3ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:3000(size=128)
Thanks a lot.

@Aravisian Has this thread been overlooked. OP has answered:

Sorry , I didn't get it . Am I supposed to do something ?

5 days ago you provided info to @Aravisian, then the thread stopped there.

@Daoudi, you did your bit by providing results asked for. Just got no reply.

Question now is have you resolved your problem or are you still suffereing log-out's.
Which app's are affected and are they by chance Snaps or Flatpak apps?

Yes, somehow, this fell off my radar.

Launching Software & Updates, then moving to > Additional Drivers
Which Nvidia driver are you using?
Also - which ones are offered, even if you are not using them?
I believe the 460 driver should still work on that card.

1 Like

I have just that Software & Updates won't launch even after using the command in terminal :
I think we now have two problems to solve .

1 Like

Can you please run

sudo apt update && sudo apt install --reinstall zorin-os-desktop

Then try launching Software & Updates again?

Sorry , still doesn't work, I ran the command and rebooted , but nothing changed .

What about

sudo apt install --reinstall software-properties-gtk

I am thinking your build has corruption. Did you check the SHA of the .iso when you downloaded and installed?
If reasonably feasible, I would definitely do a full re-installation of the Operating System.

I have ran that command earlier today (I have found it on askubuntu) .
I also think there is some kind of corruption , and I have no idea what SHA is .
So if i wanted to reinstall zorin , do I need to goo through the regular installation(download iso , put it on bootable usb , install ...) or there is a way sins I already have zorin installed ?
If not , do I use the same ISO I have , or should I download it again ?

This method. I would definitely download the .iso again just in case the download process is what created the first problem.

Please see this guide here:

Thanks a lot ! You're the best

1 Like

Hi , It's me again with my endless problems .
I have downloaded a new iso , put it in a usb using balena etcher ...
When I boot from the usb , zorin does its thing as usual , but this time it asked me fro a username and password , on the installation . When I installed it the first time , it didn't ask for anything .
Whatever I try doesn't work , I have no idea what kind of authentication that is !

I have no idea... Are you able to recall exactly when this was asked?
Do you have a Username and Password set in your BIOS / EFI Settings > Security tab?
Did you check the box for Encrypted install? (Don't).

I don't think it's my BIOS , because I have previously installed ubuntu twice , then zorin that I'm using now , but when trying to reinstall it , it asks for a Username and Password .
Does it probably have anything to do with the fact that one zorin is already there (ubuntu didn't seem to have this problem)

I am not aware of what application would be requiring a Username and Password.
Are you able to post a screen photo?