Zorin menu enter key bug - VMWare

Hi, I'm not sure if I'm the only one that's seeing this, but often when I search for something after opening the Zorin Menu and then press enter it puts a space in the search text instead of launching the first result. It actually creates a white square next to the text. This does not only seem to happen when I type very quickly. The text I mostly see it happening with is "terminal".

This is on a pretty fresh install (1 day old) running on a VM.

Welcome to the forum!

I have not experienced this issue, but i did not install in a vm either. I don't know if your aware, but terminal can be accessed by ctrl+alt+t. I'm not trying to downplay the issue, but if there's a keyboard shortcut...

Are there any other search terms this happens to regularly? I would like to attempt to duplicate your issue? Have you installed any software, DE's or drivers recently?

Hi, thanks for the quick reply.

It happens for "calendar" as well.

I installed Zorin on my laptop directly as well and I don't see it happening there. The VM install is more or less the same, no extra drivers, DE's other anything other than basic apps.

I think it's more related to the VM being slower. When I type "terminal" or "calculator" fairly quickly on my laptop I notice that the selection of the first item does "flash" a bit (meaning it briefly becomes unselected) and because the VM is slower I might be hitting enter during that window which causes it to send the enter to the search instead of the selected item.

It happens more often the faster I type for sure, but I have had it happen once or twice after waiting a few seconds as well.

At least I know it works properly outside of the VM so it's not too bad.

Could you please tell us which VM you are using?
VirtualBox or VMWare?
What is your hosting OS?

Also it is important to have an "adequate" amount to resources allocated to the virtual machine (not too much nor too little).

I'm using VMWare on Windows 10.

I've allocated 8gb of RAM and 32gb of storage to the VM which I believe should be sufficient. Running at 1920x1080 with 3d acceleration turned off (seems to be smoother).

Let me know if anything in my configuration stands out as lacking and I'll try with more.

How much RAM do you have in your machine?
It should be less than 50% of the total memory.

Also the allocation of graphics memory is important.
My old graphics card has only 1GB RAM and I had to replace it with 2GB version to make VM to run smooth. (I run Win10 guest in Zorin host).