Zorin Mouse Issues with MC

Hey, I just installed zorin, and downloaded minecraft. Whenever I open minecraft Zorin does not allow me to click on any elements, not the taskbar, not the app launcher, nothing. I know it's not because of lag or anything because I can still type with my keyboard normally. Also fyi, I am trying to download Lunar Client, a launcher for Minecraft, as this is the main way I play mc. I also tried with the normal launcher, and Badlion Launcher. All the same, nothing works.

Can someone help me? I also tried re-installing windows, but for some reason I cant launch the iso on zorin to launch the installer. I also tried to use the Windows Media Creation tool on another pc to make a bootable USB, but it would not let me boot. I tried 5 different USBs, just to be sure it wasn't a faulty USB.

Can you detail how you downloaded and installed MineCraft?

I did not know Minecraft came in .iso format. In zorin you can mount a .iso, right click on the iso and select "open with" from there in the list you can find the tool.

When referring to the iso, I was talking about downloading Windows and trying to reinstall. I know you can mount the iso, but when I go into the Windows iso, and click setup.exe it says I'm missing dependencies and wont work.

I downloaded them all from their respective websites.

Your trying to install Windows from within Linux ? I don't think that will work.

You need to download the windows iso and use a program like popcicle to make a bootable usb drive. When that is finished just boot the usb and install windows like you did with zorin.

1 Like

It will not work. Period.
.exe files under Linux will be opened by Wine, but it is only for some compatible Windows software and definitely not for Windows OS itself.

1 Like

Yes but I can not boot to the usb, I tried that already. upon booting it flashes the windows icon for a tenth of a second, then goes black, with a flashing underscore, as if its trying to start it. I let it run for a while to see if it was just slow, but no. I tried with other usb sticks also, 1 with rufus, 1 with etcher, 1 with the media creation tool, 1 with popsicle, and 1 with woeUSB. Nothing worked. By the way, i'm on a legacy bios, not uefi.-

I have legacy BIOS dual boot.
As far as I can remember, I had to make a Windows installer USB in Windows - which you do not have currently.
A kind of catch 22 situation.

The only work around I can think of is installing Windows on VirtualBox or VMWare and make Windows installer USB in it. There is a 3 days of grace period you can use Windows without activation.

1 Like

I made the installer usb on a seperate machine, on windows, and it still did not work.

Did you prepare it in MBR?
It must be in MBR to install on legacy BIOS system.

This is how it should look like in Rufus. (Our recommended bootable USB writer). Example shown is Ubuntu, but you can also use it to create Windows installer USB.

In windows i used this one alot for linux distros. Never failed me

OP needs MBR not UEFI installer.
Do you think this one can do it?


He can try it out, i dont know if it can. Silly me :sweat_smile:


There are still many machines from 10 + years ago, which run on legacy BIOS only. I am glad @Baby_Yoda informed us that he is using legacy BIOS. That saved a lot of time for us to give him an appropriate advice for his setup.


I missed that part :woozy_face:


We all do that time to time :woozy_face:


will try, tysm


Never thought baby yoda would visit us and use zorin os.


lmaoo yes

1 Like