Zorin not booting up on LG gram 17 2021 model

I am having trouble running ZOrin os live USB on my LG gram 17Z90P model.
all arch based linux boots and installs but all ubuntu based linux are not booting up, Ubuntu 22 version does not boot saying out of memory. I know there is some setting in Bios i have to change but dont know which setting, so far I have disabled secure boot and platform manager is disabled. Anyone in similar situation with LG gram

If there is a raid array, it will have to be disassembled and rebuilt, this can cause many types of errors (usually disk not found though). If you have NVMe drives, they may need to be set to raid in order to work properly.

Depending on how new your hardware is, you may have to package newer firmware or even a newer kernel with the installer in order for zorin to recognize the hardware. Zorin is currently on the 15.4 kernel i believe. I know some of the arch kernels run nightlies or rolling distros, which gives you the latest kernel and firmware. Even Ubuntu is running 15.5 or 6 in 22/23. The installer is still on the 13 kernel if i remember correctly. Zorin 16.1 started with the 13 kernel and has since been upgraded through 15.4.

Would you mind giving a little more info regarding your machine (ram, drives, cpu, gpu)?

1 Like

Its intel 7 11th gen 16 Gb Ram 1 TB SSD, its 2021 version. So fairly new machine. and its USB booting up but then does not go any further. and bootloops

Can you please name all the OS it ran before?

1 Like

So its on windows 10 and dual booting to Manjaro, I also tried Garuda and KDE versions. but all arch based and none ubuntu based. i was very much interested to try Zorin OS version, as it looked amazing. but to no avail, USB shown boot screen and then does not proceed. tried adding pci=nommconf on grub menu by pressing E and then ctrl+x or F10. but it just bootloops

This may be a graphics issue.
The following guide covers not just Nvidia, but also AMD or Intel graphics if you have those:

I will try that but my error is more like out of memory. and then it bootloops

With 16 gigs?
4 gigs would be plenty, even.

In your BIOS, you might tap ctrl+alt+F7 (which is specific to your machine) to include the hidden advanced settings.
See if you have "Intel Advanced Menu"

EDIT: I just did some searching and found another user that said you need to remove all UEFI Secure Boot, not just disable secure boot. This may also be what is needed...:

I thought if i do that woindows wont boot, but yeah worth trying. I will do that and report back here, it says intel advanced menu in advanced setup. Also could you give me link where you dound this one. I have been searching ages and could not find this solution.

So I tried that also. after LIve USB showing up option i select zorin OS shows blank screen and boot loops.

Looking around:


It appears that you are not alone in this.

Similar to your Out of memory error:

Suggestions offered so far are
Disable Secure Boot and disable SGX in the BIOS / EFI settings.

Use the Open Source Nouveau driver instead of the Nvidia Driver (You mentioned not having Nvidia card...)

Thanks and after trying all solutions its still not working, I must say i have not found SGX settings in bios

Have you tried disabling Platform Manager in Bios Advanced Setting?
Advanced BIOS settings are supposed to be reachable by ctrl+alt+shift+F7

yes i have disabled platform manager. so far I have managed to install all Arch based linus and debian based DEEPIN, which i am loving currently, but Ubuntu based zorin is not even booting up. I am sure that it has to do something with bios settings, but dont know what as mylaptop is pretty new

And Secure boot is disabled?
A user here said:

I've struggled with this since April. Virgin USB2 Stick with image from Ubuntu distribution. 64bit, 21.04. Created from standard Ubuntu 20.04 system. I'm trying to boot a 10 year old intel computer with nice hardware. The memory stick works on all of my other computers. SOLUTION: I went into my BIOS and increased the Hard Drive spin-up boot delay from zero to 10 seconds. (This computer doesn't even have a hard drive!) Everything booted normally and I'm now looking at the desktop with the Ubuntu Happy Hippo. Apparently, the USB2 stick boots too slowly.

yes disabled secure boot, i dont thing usb drive is problem, as its booting up and showing UBUNTU boot up option, but then bootup process comes up with out of memory error

Searching this, I noticed this thread:

It refers to Ubuntu 22.04 but references bug:

The grub version is the same...

answer is here

I changed Max TOLUD to 1.5 gb ( it was dynamic). And I could boot up and install, and now typing from my brand new ZORIN OS, very happy, thanks for all you guys helping out, but this is the answer and all Ubuntu based OS i can install now.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.