Zorin not detecting second monitor after reboot

Before I rebooted, the second external monitor was working fine. Then I realized that my terminal application was not opening (different problem, I will port if not fixed later), so I decided to restart. I didn't unplug anything, but it just does not detect it anymore. So keep in mind I cannot open my terminal so that is another big problem.

Check Additional Drivers see if you need driver updates.

Software Updater > Settings > Additional Drivers

Software updater isn't opening either. In the bottom right corner there is a red circle with an exclamation mark and when I click that is says that there is a problem checking for updates

Can you try Ctrl+ALT+F4 and see if the terminal login loads?

login with username password

and see what

sudo apt --fix-missing update
sudo apt clean
sudo apt update
sudo apt upgrade

if apt won't run try
sudo dpkg --configure -a

How do I exit the terminal? I went into it, but before I could do anything I wanted to make sure I could exit it.

CTRL+ALT+F2 should bring you back to the Logged in Desktop ctrl+alt+f1 will start a new session

after running the commands i would recommend an immediate reboot

It says that my login is incorrect. am I putting in the wrong username? I dont know how to check the username, but Im pretty sure I know what is it. Sorry for asking, I am new to Zorin

username is case sensitive, since you don't have access to the terminal app,
open file manger, goto Other Locations > Computer > Home the folder will be your username in my case my username is sean all lowercase
Screenshot from 2023-03-09 11-48-30

Screenshot from 2023-03-09 11-48-50

i ran the command you gave me, and the first one gave errors, I couldn't copy so I cant show you. The rest worked, and I rebooted nothing was fixed. Terminal still inaccessible and monitor not detected, and softyware updater also inaccessible.

You can enter the TTY terminal with ctrl+alt+F6 and exit back to the desktop with ctrl+alt+F7
Can you enter TTY and run

sudo apt install --reinstall zorin-os-desktop

Report any errors here.

1 Like

Tried this and rebooted, nothing fixed :confused:

General apps not loading and monitor also not recognized.
It sounds a lot like corruption in Root- Bad sectors or hard drive failure.

So is only answer reinstalling? I really wouldnt want to do that, as it took a while to get it setup.

I would first suggest running diagnostics on your hard drive. Files cannot just delete themselves- but disk failure can cause files to become inaccessible.

1 Like

Im astonished by thr fact it could be disk failure. This disk has never, and I mean never, shown any signs of wear on my laptop in a year or so. But it happens. So afyer disk diagnostics, what would that help except for making sure it is the disk that is the problem, because i would reset it anyway? I havent had this problem with any other distro...

It is the primary reason that comes to my mind for installed files becoming inaccessible.
We do not know that there is drive failure - this should be tested using S.M.A.R.T. or other diagnostic tools.

If we assume the drive is in working order, then we have a mystery as to what caused such a catastrophic failure... But it most likely will result in re-installing your operating system.

It's a computing problem. I mean, if a component on a car happened to go out, you wouldn't likely consider that you never had it go out on other makers cars.
It's just machinery. Sometimes, things go wrong.
I have had to reinstall Windows OS many times due to very similar troubles, too.
It can happen on a Mac much the same way.

This is why in computing, we are constantly reminded to Safely back up data.

In Zorin, is there a way to sync files between installs, or should I just use Google Drive or something of that nature?

Yes, using cloud storage or reliable physical storage is the way to back up personal data.
You can also read here:

To test how good or bad your hard drive is, launch Disks (enter Disks in the search bar of the menu) and click on the 3 vertical dots and choose the SMART Data & Self-Tests ... option:

Gday @kirillmcq Welcome to the community!

With all the great help above,,
It looks like a corruption has occurred at some point ( Stating the Obvious :smile: )

I would suggest to reinstall ( easy way around)
First can you tell us your pc spec's?
Drive/s:type & size.
Also are you wishing to dual boot or clean install?

Next :
Can you tell us what program you used to create the bootable usb drive with?
Where did you get the .iso file from?
Did you run a checksum to verify the download?

Do you have fast boot disabled?

Reasons for the corruption can be vast, From a bad download, faulty hardware to power surge's.