Zorin not installing on second laptopDr

Hello Again,

After having some problems with USB drives with my first Zorin installation on 1 laptop, I was able to resolve the issue with help form this forum. So then I became excited with Zorin such that I decided to install it on my main laptop, but now I am stuck again only with a different problem, so I am here again requesting some guidance.

I choose the installation with the NVIDIA option because this laptop has a GeForce GTX 1080 with Max-Q design version 431.53(found this info from system information window in windows prior to wiping it out to install Zorin).

The installation was fine until I started tinkering around. I wanted to learn how to create new user accounts. I did create an account but when rebooting, I get a black screen with a border for a few seconds and then it changes to a completely black screen and no further booting occurs.

So I decided to try to reinstall Zorin again with the same NVIDIA installation option but it doesn't install, instead, the new installation does the same thing. It boots to the black screen with the border and then goes to the black screen and nothing happens.

To be clear, it will boot from the USB and I can perform the installation process with ease. The problem begins when rebooting from the hard drive.

At the moment I am simply doing trial and error with the various installation options to see which one works.

I am hoping one of the installations options work such that I can get to boot and then update NVIDIA drivers assuming it's the video drivers that is affecting the display.

But secondly, even if there was a more sophisticated way to troubleshoot without reinstalling, my question is why can't I reinstall?

While I try the installation options, If anyone can point me in the right direction to get Zorin installed, please comment and let me know.


Perhaps your laptop is to new for the Z15.3? Maybe try Z16 beta.

Thanks I will try 16.0, but I do need 15.3 to work at least for a while.

I was able to get the 15.3 to boot when using the Nvidia option which ends with --class. Does anyone know what --class means?

And it only works if I don't connect to the internet and if I don't select the option to encrypt the hard drive. Therefore, it's a no go with internet and encryption during installation.

I would like to have encryption, so does the above description provide any clues as to how I can solve this problem to get encryption?


Encryption requires LVM.
The very first thing I would ask is if you really need full disk encryption. Unless that notebook is highly travelled and carries very sensitive information, you probably do not need it and full disk encryption is overkill for the average user.

Not connecting to the internet during installation is fine. Once the installation is complete, you should be able to then connect to the internet and update your drivers.
What is the Integrated Graphics build?

The --class references the actual operating system for the Grub menuitem list.
For example, let's say that you are Triple Booting Mac, Windows and Zorin, you would see the following class options:
--class osx --class sierra --class os
--class windows --class os
--class gnu-linux --class ubuntu --class zorinos

The above are just visual examples; but should convey the meaning.

If it was me, I would not boot with the Nvidia option at all. I would boot with the Integrated Graphics, first. Then set up and configure the Nvidia drivers.

I did this and ran the software updater and I noticed nvidia 450 driver installed among everything else that is updated with this updater.

And I am replying from the laptop running Zorin.

Understood, but the encryption option not working is less than perfect and is bothering me such that I would like to fix this if it's possible to fix it. Do you think this is this fixable or do I have to accept it? Is it simple to fix if fixable?

Again, thanks.

Nvidia may be trying to access information during boot that it cannot access if the drive is encrypted.
If this is occurring during boot and before you can enter your password, then it may be the Splash Screen causing the issue. If a person uses a custom grub menu (as I do) or custom grub background (I also do this), then those would have the same trouble.

For the common splash screen issue, you can edit the grub parameter to change it from splash screen to text:

sudo nano /etc/default/grub

FInd this line:

and change to
Keep any other parameters in place if you have them.
For example, if you had GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset" it would change to GRUB_CMDLINE_LINUX_DEFAULT="text nomodeset"
Press ctrl+x to exit, then the y key to say yes to save, then the enter key to save as current configuration.

Am I making this change at boot on the installation with the encrypted drive which is not booting pass the black screen? If so, where am I making this change?

I did enter it in the terminal on the installation I am currently using which doesn't have the drive encrypted and I see

You can hit the e key on the installation Boot Screen to edit grub from there, though the lines will look different. Just scan the screen for "quiet splash" and you will find your place.

Doesn't exist, but I did see quiet splash in a different line and when I replaced it with "text", it contunued booting with text scrolling up the screen and eventually went to the same black screen.

However, I selected advanced options on the GRUB screen, then zorin recovery mode which booted with lots of scrolling texts, and eventually requested that I unlock the disk sda5_crypt. When I typed my key, it booted into a recovery menu where I selected resume normal boot and it booted into zorin.

And I have to do this every time I boot, otherwise it goes to the black screen.

Did this expierence provide any clues to get me closer to a solution?

If you access grub from the Grub Menu Editor, then you will not see this line:
Instead, it will look just as the screenshot in the Link I Posted Above.

If you access the Grub File while booted into linux, (In this case, Zorin OS), you will see the line:
normal and in the file.

As covered above in post 6:
Nvidia may be trying to access information during boot that it cannot access if the drive is encrypted.
By unlocking the encrypted drive, you are able to boot.

Once you are Booted In Normally (after unlocking the encrypted drive), please refer to the instructions above:

sudo nano /etc/default/grub

Find the line
and please continue from there...

I did, but it booted to the same black screen.

Link back:

No change. It booted to the black screen.

Honestly, I am stumped at this point.
Unless both of your computers have a particular Nvidia card that is not well supported by the drivers available... and what are the chances of that?

I do have a perfectly good encrypted installation on a different laptop, but that laptop is booting fine and is not the one I am trying to fix.

The problem laptop is the laptop with an Nvidia card booting to the black screen under 2 different situations.

The first black screen encounter is when the drive is encrypted during the installation. It boots to the black screen but can boot to Zorin if recovery mode is selected.

The second black screen encounter is on an installation with a non-encrypted drive on the same laptop which boots fine when automatic login is selected, but when I select the option to enter my password to login during boot, then it boots to the black screen. And the reason why I experimented with the manual login is because I am trying to get the option to select the plasma desktop which is an option when plasma is installed(according to the videos I watched on installing and booting plasma)

These two installations are not dual boot. Only 1 is installed at any given time.

Just to followup on this if it might be useful. Drive Encryption worked with Zorin 16 and also Garuda linux, but it didn't work with Pop os. My expierence with Pop os was exactly the same as Zorin 15.3.

Also, the plasma desktop installation worked with Zorin 16.

Do I need drive encryption? No, but I got more familarity with the linux environment in the process of pursuing a solution.

Again, Thanks.

1 Like