Zorin on chuwi gemibook pro

I tried installing zorinOS on my chuwi laptop and i have graphics issues. The screen flickers and sometimes moves from left to right. It stops when i close the laptop and open it again, its frustrating. Anyone knows what the issue is? I tried posting on other forums but got no info or help whatsoever

Hi and welcome to the forum.
Can you please post the spec of your particulat laptop model, including what graphics card/chipset it has.

Ok the specs are
Intel Gemini Lake Refresh J4125|

Intel UHD Graphics 600, 250-750MHz|

|RAM (Memory)|
LPDDR4X 16GB, 2133MHZ||

Hope this helps

This happen with other distro?

Im try to install Linux on chuwi V10 plus with no lucky.

Yes with other distros also

OK, you don't have a discreet GPU, yours is integrated in your Intel CPU. What we don't know, is what kernal version you are using.

uname -a

Post results here please.

Did you install zorin with safe graphics ?
You can try to load with other kernel to see if this happen to.

Thats exactly what I was thinking, which is one of the reasons why I asked the OP what kernel version they were running. They could try kernel 5.11.36, or kernel 5.11.34, to see if either of those work better on their system.

Ok, how to change kernels?

After powering on your computer, hold down the LEFT SHIFT key to enter GRUB menu. Select advanced options from the menu.

From there, you want to go to boot Zorin with a different kernel, choose a lower version, and see if your system operates better.

Nothing happens when holding the left shift key, the system boots up normally

OK, you may have one of those other computers that require you to either tap ESCAPE a bunch of time, or hit the F12 key a bunch of times. Yeah I know, I don't know why all computers are different and never follow a simple standard.

Esc did the trick. There was only kernel 11.27. available. Tried it and the problem is still there. Any suggestions?

Looks like its back to windows for me. Thank you guys

Dont switch back yet, did you try pop os 21.04 ?

1 Like

Try this to see if works

Yes and the results were the same. Same with manjaro, fedora and ubuntu. Too bad as i really like linux more than windows. Maybe this device cant handle it

Did you try this ?

  1. sudo apt-get install mesa-utils
  2. sudo mkdir -v /etc/X11/xorg.conf.d
  3. echo -e 'Section "Device"\n Identifier "Intel Graphics"\n Driver "Intel"\n Option "AccelMethod" "sna"\n Option "TearFree" "true"\nEndSection' | sudo tee /etc/X11/xorg.conf.d/20-intel.conf
  4. reboot

No but i have changed the resolution to 1600x1024 and it looks like the problem is gone

1 Like