Zorin OS 15.03 lite not booting after resizing root partition

I am dual booting zorin os 15.03 lite with windows 10. When I resized the root partition from a live usb with GParted, I could not boot on zorin os again. When I try to do so, I only see this screen.

When I try to boot on recovery mode, I see this.

So, I tried to repair boot with 'boot-repair'. I installed this on my zorin os live usb. When I run 'Recommanded Repair' , I get this messege, "grub-efi-amd64-signed purge cancelled. Please report this message to boot.repair@gmail.com". then I created a "BootInfo Summary" with the app,and here it is.
Can any one help me please??
(Note that Windows is installed in UEFI mode, where Zorin os is installed in Legacy Mode. My hardware and both system is in 64-bit.)

I believe you answered part of your own question. I don't know how you did it, but to install zorin in legacy while windows is in efi is nearly impossible. Legacy uses the mbr structure which limits the number of primary partitions to four and the rest are extended partitions(again with a limit). Efi uses the gpt structure allowing for many partitions, all bootable of necessary. These structures are so different they don't work together. That may be part of your problem.

As for resizing partitions, did you ensure fast boot and secure boot were off in the bios? If it's on the same physical drive as windows you may need to boot windows, press windows key+x -> power options -> choose what happens when i close the lid or choose what happens when i press power button -> left click the shield symbol and accept to allow changes in bottom half of screen. Uncheck fast boot. Save and exit windows.

Also, never resize a partition that is bootable while your in it. This can have disastrous effects and make your system un-bootable. I'll do a little research, but you will probably have to reinstall.

Boot from your live usb, access the try zorin option.

Under the app menu (zorin button) open boot repair.
Under GRUB options select "purge GRUB before reinstalling it"

This should reinstall grub, after removing the broken version.

Reboot and try to enter zorin.

If this doesn't fix the issue you will most likely have to reinstall. Whatever iso software you are using, please reformat your usb to use efi option (gpt) and this will avoid future headaches. Legacy mode isn't necessary unless you are installing to older hardware.

@337harvey Just to flag that I think the OP used his Live USB Gparted to adjust the partition, not Gparted from installed OS.

I would hope so... but i was unclear whether that was the case. Read over that to quickly.

Hypothetically asking, under normal circumstances, if the OS partition is resized, Zorin will still operate normally correct? I've done this a number of times before with Windows, but I've never done it with linux. I assume it's going to be fine.

Yes, that should not be a problem. I've re-sized Zorin and other Linux partitions without difficulty, using Gparted. There's always some risk when repartitioning of course, but generally it's fine.


Looks like, I've figured out the solution myself :sweat_smile:! What I did is just created a 2 MiB unformatted partition with BIOS_boot flag and installed grub from live USB just as instructed here. And, it fixed my problem! Btw, thanks for replying on my post :grin:!

YES! I was(and still after the repair) running. And moreover, I am also able to boot windows from boot menu in both legacy and UEFI mode. Where, I can only able to boot Zorin OS from only Legacy mode. I don't know how (I was also surprised when I first discoverd this), but I can!