Zorin OS 16.2 Core with Realtek RTL8812AE TPLink Pcie wifi adapter has issue in upload speed throttling at 5 Mpbs Max

Hi All,
I freshly installed Zorin OS 16.2 Core in desktop pc which has TPLINK PCIe wifi adapter ( TP-Link AC1200 Wireless WiFi PCIe Card | 2.4G/5G Dual Band Wi-Fi PCI Express Adapter) . Issue is, when i choose 5Ghz wifi access, i see that the download speed is good but not consistent, while the upload speed throttles at 5 Mbps max .

Same issue

First check the hardware

Unplug and re-plug the adapter, remember that it will only work on USB 3.0 ports, and it won’t be recognised by USB 3.1 ports. Check the output of:

$ dmesg

The following commands will also help in showing if the adapter is correctly detected.

$ lsusb

Bus 004 Device 002: ID 4791:205a G-Technology ArmorATD

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Bus 003 Device 002: ID 2357:0103 TP-Link Archer T4UH wireless Realtek 8812AU

Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The Bus 003 Device 002: ID 2357:0103 entry above is the one with the USB Wi-Fi adapter on my system. You can remove the adapter and issue the command again and compare results to help you identify yours.

For non-USB adapters you can use:

$ lspci

More detailed information about the device can be obtained with the lshw command.

$ lshw -C network

WARNING: you should run this program as super-user.

*-network

description: Ethernet interface

product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

vendor: Realtek Semiconductor Co., Ltd.

[output truncated]

*-network:2

description: Wireless interface

physical id: 4

bus info: usb@3:1

logical name: enx18d6c70fbacc

serial: 18:d6:c7:a1:22:ab

capabilities: ethernet physical wireless

configuration: broadcast=yes driver=rtl8812au ip=192.168.x.2 multicast=yes wireless=IEEE 802.11AC

WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

This last command is really useful because it will give really important information about what driver to use.

In this case the chipset and driver to use is identified in this string driver=rtl8812au. We already knew this in any case. If yours is a different driver/adapter this solution is unlikely to work for you.

Checking the drivers

Now check that the driver is loaded, you need to look for a string that is similar to the driver string above.

$ lsmod | grep 8812

8812au 999424 0

If the module isn’t loaded you can manually load it:

# modprobe 8812au

Installing updated drivers

If all of the above seems to work but the Wi-Fi adapter isn’t detected you can install the drivers manually.

The version of the drivers is newer than the ones provided via apt.

Uninstall the system provided drivers

From the GUI:

  • Go to Software & Updates
  • Select Additional Drivers
  • Find the entry for the Wi-Fi adapter (rtl8812-au) and select Do not use the device

Or from the CLI:

[find the installed driver]

# apt list rtl8812au*

[and uninstall it]

# apt purge rtl8812au-dkms

Install alternative driver

Get the updated drivers from github:

$ git clone https://github.com/gordboy/rtl8812au-5.9.3.2

Move the source code to /usr/src so that DKMS can automatically build the driver when the kernel is updated.

# mv rtl8812au-5.9.3.2/ /usr/src/

Build and install the drivers:

dkms add -m rtl8812au -v 5.9.3.2
dkms build -m rtl8812au -v 5.9.3.2
dkms install -m rtl8812au -v 5.9.3.2

Check that the driver is installed correctly:

# dkms status

Additionally:

[Make sure that in /etc/NetworkManager/NetworkManager.conf]

# vim /etc/NetworkManager/NetworkManager.conf

[The following entry is inserted]

[device] wifi.scan-rand-mac-address=no

If the driver is recognised you can configure the wireless network as normal. Restart to make sure everything works and remains persistent.

Uninstall

If you ever need to uninstall the driver you can do it with:

# dkms remove -m rtl8812au -v 5.9.3.2 --all

If you edited /etc/modules you will need to revert the changes. In the previous tutorial for Ubuntu 18.04 the module had to be added manually. It isn’t the case for this version.

2 Likes

Hi @Michel ,
Thanks for your time. Just curious to know if these steps are applicable for PCIE based wifi adapter as well. Just to reiterate, the issue isnt that wifi adapter is not sensed. But the issue is download speed keeps varying some somewhere between 140-30 Mbps whereas the upload speed throttles at 5 Mbps.

just to add the output

$ lshw -C network
WARNING: you should run this program as super-user.
*-network
description: Wireless interface
product: RTL8812AE 802.11ac PCIe Wireless Network Adapter
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlp3s0
version: 01
serial: d0:37:45:9e:e1:73
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rtl8821ae driverversion=5.15.0-53-generic firmware=N/A ip=192.168.1.15 latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:31 ioport:e000(size=256) memory:f7c00000-f7c03fff

***********Just the output of the Wireless part

$ lsmod | grep 8821*
rtl8821ae 331776 0
btcoexist 245760 1 rtl8821ae
rtl_pci 40960 1 rtl8821ae
rtlwifi 114688 3 rtl_pci,rtl8821ae,btcoexist
mac80211 1249280 3 rtl_pci,rtl8821ae,rtlwifi

after this, i ran the speed test again to check and here is the result.

��<�pre>$ speedtest --secure Retrieving speedtest.net configuration... Testing from Airtel Broadband (122.174.171.189)... Retrieving speedtest.net server list... Selecting best server based on ping... Hosted by ACT FIBERNET () [21.06 km]: 8.958 ms Testing download speed................................................................................ Download: 161.52 Mbit/s Testing upload speed...................................................................................................... Upload: 5.64 Mbit/s <�/pre>

***** Now I ran the apt list command to see nothing, i mean no results****

$ sudo apt list rtl8821ae
Listing... Done

So now, i am not sure, what to purge??

Thanks

Check out