Zorin OS 16.2, showing brief errors before startup, on Dell XPS 9520?

I have had a Dell XPS 9520 Laptop since 2022 with a spare internal SSD I want to use for a Linux OS.

Here are the specs:

i7 12th Gen Intel CPU
NVidia RTX GeForce 3050
Intel Iris X Graphics

The issue is when I tried installing Zorin 16.2 at the time, it kept showing a brief error at startup boot which I know is not meant to happen at all.

Ubuntu 22.04 OTOH kept on freezing my screen whilst on the install or try option while I was using the USB Drive.

So now I am wondering is there any Linux distro I can try and install that will work with my modern computer configuration without any issues?

Any help will be great!

See if anything posted here helps:


1 Like

Gday @Z_123

The errors you see flash before the OS starts can be due to many reasons such as including hardware issues, misconfiguration, missing drivers, or software conflicts, etc etc etc.

If the OS continues to boot & all run's well, These errors can correct themselves or just be ignored by the system, with no effect on anything.

If you wish to hide these errors you can via the below method,This is the same as @swarfendor437's link, just a little more "how to".

Personally i see a flash of approx 6 lines, this pop's up twice on my pc before the OS loads.

As i know i have a faulty M/B, i choose to let these errors run, when i see more errors than normal i'll know it's time to replace it :slight_smile: But i'll prob replace it before then, (i hope :slight_smile: )

Open GRUB default file & add: (loglevel=3),inside the ("") of the line (GRUB_CMDLINE_LINUX_DEFAULT="quiet splash")

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=3"
Open the GRUB file to make changes;

sudo nano /etc/default/grub

After adding the parameter,
ctrl+o, To Write the changes.
Then Enter, To confirm changes & correct path.
Now Ctrl+x, To exit the file.

Next run:

sudo update-grub

Hope this helps.

1 Like

If you're using Windows only on that laptop - before booting your USB, make sure that you shutdown instead of rebooting.. That one got me for a little while. I dual-booted my Zenbook 14 with 16.3 Core - first time going into Zorin after the install using a reboot.. no sound. Took me a min to figure it out but, new Windows systems have like a hybrid shutdown / sleep. Regardless of fast startup settings, that will take over some busses - just FYI..

As for the rest, are you disabling Secure Boot and any RAID options in BIOS? Wouldn't hurt to poke around some options in your BIOS to see what might be there or enabled. Avoid any 'quick' or 'fast' startup options in BIOS - enabling this will make it extremely difficult to reenter BIOS afterward. Just a forewarning - it sounds like a good setting but it is in fact not lol..

I would try again from a powered off state, any BIOS options like Secure Boot or RAID (enable AHCI instead) disabled, and see if that works. I have an 11th gen i7, MX450 Nvidia GPU / Intel Iris GPU, and a screen for a touch pad - all work. It sounds like maybe something is just not playing well, or enabled that needs disabling - could be a number of things!

If you have working system and need to see the boot log, in terminal issue: sudo cat /var/log/boot.log to see what might have failed. If it's a very short message about SGX, you don't need to worry about that - unless you're in a hospital or government setting. It's an added layer of application code exploitation protection.

I do have Windows 11 on the SSD in the 2nd slot but the 1st slot SSD currently still has Zorin 16.2, should I simply install the 17th version of Zorin erasing the 16.2 on the SSD or something else?

.2 or .3?

Installing 17 would be up to you - 20.04 (Zorin 16.x) is rock solid but, may see better results with 22.04 (Zorin 17.x) and newer hardware.

But, before that - do you have any RAID or Secure Boot options enabled in BIOS; and is your Zorin install booting?

No both the secure boot and RAID are disabled.

However recently I am seeing the text "secured by safe BIOS" on top of the Dell logo everytime I boot up my PC...

So if you know the answer to my questions please tell me!

Try checking your Secure Boot Mode in BIOS - just watched a video on Dell BIOS settings. Seemed to have Audit and Deployment? Not sure what one would do vs the other honestly - Audit mode stated that it does still use UEFI driver enforcement or something of that nature.. maybe Deployment mode would disable that too? I haven't played with Dell's in a looong time myself :sweat_smile:

The message at boot - may be the Grub message for SB status. You can set to disable through Mokutil if it isn't already. Check with mokutil --sb-state; if it returns 'SecureBoot disabled' then that should be fine. If enabled, then you can use Mokutil to disable - sudo mokutil --disable-validation | it'll ask you for your password, and then another password in Mokutil - temporary password, when you reboot you'll enter that password when Mokutil displays, then select to disable Secure Boot, then reboot.

I've changed the Topic title as it's more an issue with the error messages prior to boot.(Other distro's may also have these errors but don't have them showing by default).

I believe we have answered that part.
To add to your question about Zorin OS 17, Yes i would recommend,Upgrading to Zorin OS17, due to you having a new machine.

Also Zorin OS is Secure boot compatible.
Hope this helps.

1 Like

This is something Dell offers, which usually includes SGX (Intel Secure Guard Extensions):

1 Like

I did not recieve the SafeBios text before, I only recently started to see it everytime I boot up my PC.

So it won't affect or compromise anything on my Zorin installed SSD will it?

What was the returned status of mokutil --sb-state?

How can I check that?

Issue: mokutil --sb-state in terminal - you can copy / paste the grey text into terminal if you need to :+1:

SecureBoot disabled - Platform is in Setup Mode.

So, turns out.. setup mode status is related to manufacturer keys in BIOS. That apparently just means that the keys have been removed / deleted; and awaiting new keys.

Reading this post makes me think it may be conflicting somehow but, not sure.. I don't want to say it does or doesn't without knowing..

I would assume (and we know how that goes..) - recover the BIOS UEFI keys, should be an option in there somewhere; or a key reset button of some kind (BIOS), reboot but don't login to Zorin, reboot again into BIOS, turn SB off and then reboot again - then check mokutil --sb-state again...... But, just going off reading - have not dealt with this SB status.

Also, the secure boot mode settings within the Dell BIOS - that may have something to do with it as well.. But, again not too sure about that one (Audit vs Deployment mode).... (edit) Audit is more forgiving it seems, and won't be a factor; so should probably be on Audit mode. Deployment is a more strict version of 'normal' secure boot enabled. Just found that out, thought I'd put that in there..

I now have a new issue where my PC boots up, it keeps getting into "Automatic Repair" and keeps failing to repair anything loop.

I can't log into either Zorin nor Windows 11!

What can I try doing now?

Have you tried Boot Repair?

Hmm is it ok if I send a link to a video I personally made showing the exact issue I currently have on my Dell XPS 9520?

By all means, that may be quite helpful.