Zorin OS 16 Core and Lite won't shutdown

Hi, I have tried Zorin OS Core and Lite version 16 and for some reason on of my HP Laptop I have the same issue where it will not shut down. I click shutdown or restart then it shows the HP Logo and the Zorin OS logo like when it is starting up. The screen goes black after that then the fan keeps going. I've left it running and obviously it has been for many hours because the battery was at about 90-100% has gone 0% in the morning on trying to boot, it will not restart or shutdown at all. I have to just hold down the power button otherwise it won't turn off till the battery runs out. I have got an HP laptop with an AMD Processor. I have tried Zorin OS 16 Core then I thought it might just be the Core version so I tried Lite and it is still the issue so maybe it is a power setting issue or some other issue. Does anyone have any ideas? Thanks.

1 Like

Can you please post the output of

sudo lshw -c display

Some users have said that resetting the CMOS battery works to resolve this.

This user says that disabling the USB 3.0 support in BIOS worked:

I wouldn't want to go that route...

description: VGA compatible controller
product: Stoney [Radeon R2/R3/R4/R5 Graphics]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 1
bus info: pci@0000:00:01.0
version: da
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
configuration: driver=amdgpu latency=0
resources: irq:41 memory:e0000000-efffffff memory:d0800000-d0ffffff ioport:5000(size=256) memory:d1600000-d163ffff memory:c0000-dffff
description: Display controller
product: Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445 / 530/535 / 620/625 Mobile]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:01:00.0
version: c3
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi bus_master cap_list rom
configuration: driver=amdgpu latency=0
resources: irq:43 memory:c0000000-cfffffff memory:d0000000-d01fffff ioport:4000(size=256) memory:d1500000-d153ffff memory:d1540000-d155ffff

I really like Zorin OS which I used to have Windows 10 but Zorin runs a lot better and doesn't have telementary issues like Windows.

So, it looks like it may not be a graphics issue...
You may also try out checking here:

...to see if this bug is affecting you.

1 Like

Try those suggested here.


1 Like

I have tried doing this and it shows a window empty so not sure what to do.

``you can do this by editing the etc/default/grub file

sudo gedit etc/default/grub - make the edit so it looks like this GRUB_CMDLINE_LINUX_DEFAULT=""

Also trying to press escape and ctrl + alt + f1 etc does nothing too.

Another one. https://www.addictivetips.com/ubuntu-linux-tips/shut-down-a-linux-pc-that-wont-turn-off/

Hope the problem will be fixed soon.

1 Like

sudo nano /etc/default/grub

To save and exit:
ctrl+x to exit, then the y key to say yes to save, then the enter key to save the current configuration.

Don't forget the;

sudo update-grub

before restarting.


Alright, now it is showing a bunch of text scrolling up and down when shutting down and turning on but it is still doing the same issue. It is not shutting down or restarting. Thanks for trying everyone but it is still not fixed.

The link I posted specified that you Remove "Quiet Splash" In order to watch the scrolling output for Reached target shutdown - and see if the process freezes at that point.
It did not say that was fix.

1 Like

Oh ok. The last thing I saw was "[Ok] Reached target Power off" then the screen went black. Maybe there is a command I can do to force shutdown instead it might be more useful?

There are several described in the links above, have you tried?

I will have to try them all.

I have tried the following commands:

sudo init 0
sudo halt
sudo shutdown now

None of them work. I guess I will just have to resort to using the hold-down button each time. Or maybe I should try Pop_OS!

Thanks for everyone trying to help anyway. :smiley:

1 Like

Even this one? Strange.

Just tried this one too and that doesn't work either. It seems a very stubborn issue. :exploding_head:

I don't know it this will help


it has similarities with Aravisian's solution but with acpi=force. Just like what it was said in the link, I also think its your machine that don't want to shutdown. It happened to me before but it fixes on its own so goodluck to you.

1 Like

I had the same/a similar issue and it turned out my laptop didn't like the kernel version. I made this post where I was helped and the problem was solved: Laptop with Zorin 16 doesn't shut down or sleep - #28 by UselessBoi

Basically I just installed the 5.11.0-40-generic kernel and set it to be the default version to boot into using Grub Customizer. You can try that if you want and see if that fixes your problem


Our internet went down here.

Problems abound, everywhere.