Zorin OS 16 Core - Cannot install with UEFI

Zorin OS 16 Core - Cannot install with UEFI, tried on three different laptops, all in dual-boot with Windows 10 and I get errors at boot. It detects the usb key. Have no problems with the same laptops using the beta version of 16. No such issues when booting and installing with legacy. What gives?

Techie, are they the same errors that you can see in others posts in this list?

@Aravisian I think its the same thing
Used the rEFInd - tool. It booted into Zorin 16 right now am just backing up Zorin 15.3 before installing Zorin 16.


Something's up, though. In the past (As in prior to yesterday), I only ever needed to suggest rEFInd for when a person was installing on a Macbook.

i agree hopefully the devs can maybe look into this


5 posts were split to a new topic: Zorin OS 16 Core install stuck at 'Choose disk'

A post was merged into an existing topic: Zorin OS 16 Core install stuck at 'Choose disk'

i3 6th gen 8gb ddr4 asus laptop

Something is definetely up. On those same laptops, booting and installing via UEFI works with other distros, no errors. I.E. Ubuntu, Manjaro etc. BTW I am using a Dell Latitude E7470 and two Thinkpads T430. I just tried yesterday trying a new USB key, same thing.

1 Like

Please see the post here:

hi probe installer desactive opcion actualitions during installation a greeting and you tell me greetings :blush: :blush:

An Update can be found Here:


The BIOS workaround worked perfectly on my Dell Latitude ! Many thanks Aravision and ZorinGroup.

1 Like