Zorin OS 16 not booting

Hi Guys, I am having a similar problem as Matt_Nico did.
I Installed on My Lenovo Laptop Zorin OS 16 Core generic installation and after installation, it did not boot.

I tried removing ro for nomodeset on grub, then I tried the following steps:

  1. Removed ro for nomodeset
    Result=> Stuck at arp filtering: 1 address (implement)

  2. Removed ro and added nomodeset noresume
    Result => Stopped at unable to bind the codec

Kindly advice. I don't know what to do.

Are you able to access the grub menu?

Yes, I am able to edit the grub before the boot.

What type of graphics does your Lenovo have?
Is the OS Freezing at the Zorin Logo? Or does it give an error?
Or... Does it go to black screen?
Or black screen with blinking cursor?

When I just let it boot, it starts booting and stops at: arp filtering: 1 address (implement).
My Lenovo is the Lenovo G470, Intel Core i3-2330M CPY @ 2.20GHz with System Memory 2048 MB. Not sure if it has a graphics card. I don't think so.

2gig RAM?
That is a bit low...

Is there anything printed prior to that line? Address Resolution Protocol... Odd place to stop. Doesn't tell much... Only thing I can think of would be Network Card right off. Broadcom?
Are you able to access TTY?

1 Like

I agree, 2GB RAM is too low for CORE, its not gonna happen I think. I think the OP will have better luck install Zorin OS LITE. Since the OP needs to get an OS installed now, I will recommend Zorin OS 15.3 LITE.

Also, I hope this Lenovo laptop isn't so old that its a 32-bit machine, because if it is, the OP is gonna need to install 32-BIT Zorin OS 15.3 LITE for sure! Does the OP know if their machine is 32-bit or 64-bit?

And if the OP doesn't know, would they be so gracious, to present us with their computers model number, so we may answer that question for them. One thing is for certain, the OP needs to forget about CORE, cause Gnome won't run on 2GB of RAM, Gnome-Shell uses up to 1.1GB of RAM alone, leaving practically nothing for the rest of the OS.

1 Like

Burn another USB using BalenaEtcher as detailed in these instructions: Install Zorin OS - Zorin however, make sure you try the Lite version of Zorin (download the ISO from here: Download - Zorin OS). You will likely not be able to run Zorin Core due to your computer specs.

Hi, answering a few of the questions.....

  1. I am able to open the TTY from the GNU Grub Menu via Edit (E)
  2. My computer model is Lenovo G470
  3. I am able to open Zorin from the flash drive that I created using balenaEtcher before installing it, so I don't think there should be a problem with the 2 GB Ram.
  4. I have a 64-bit operating system
  5. I have installed Zorin OS 16 Core while maintaining my Windows 7 Home Basic Partition
  6. Intel VM is enabled on BIOS
  7. When I just let it boot, then it starts the Zorin Logo and stops on the black screen with the following output:

brcmsmac bcma0:1: brcms_ops_bss_info_changed: 1os enabled: false (implement)
brcmsmac bcma0:1: brcms_ops_config: change power-save mode: false (implement)
brcmsmac bcma0:1: brcmsmac: brcms_ops_bss_info_changed: associated
brcmsmac bcma0:1: brcms_opss_bss_info_changed: qos enabled: true (implement)
brcmsmac bcma0:1: brcms_opss_bss_info_changed: arp filtering: 1 address (implement)
(stops here with blinking "space line")

Please kindly advice. Thanks!

From the Hardware Manual:

AMD Integrated
Intel integrated
That doesn't help LOL

Avi, as a complete shot in the dark, you might open TTY and run the following:

systemctl disable NetworkManager-wait-online.service

Then test boot up.

As others already pointed out, for this amount of memory, you would not be very happy even after managed to install Zorin 16 Core.
My recommendation is other light wait distros such as LinuxLite or BhodiLinux or MXLinux.

The Try Zorin LiveUSB does not really use your RAM, by the way. "Try Zorin" is a demo - a test run, really...

1 Like

As stated it's always good to look at Zorin 16 reqirements before considering install. Caveat Emptor that going with the very minimum in my past experience with anything is not really good. Looking would have (and I know your anxious to explore :grinning: ) gave the a idea of success right now. And I look forward to lite myself many are churning in wait

Hi Aravisian, I tried this command on the grub menu Edit for command line (grub>), but it did not recognize the command systemctl

Hi Bubby, the system requirements are met, that's why I installed the core version.

Thanks! It makes sense. However, the system requirements are met for CORE installation.

Hi Aravisian, I was able to drop to root shell prompt and run the command.
It failed by replying=>
Failed to disable unit: File /etc/systemd/system/network-online.target.wants/NetworkManager-wait-online.service: Read-only file system

Yea I knew that's what you thought but it takes 35gb just to install( room to move) knowing from past attempts. And I have never ran anything successfully on barebones. 15gb is the space occupied on disk I act believe its 20 gb from my installation. 2gb if you run it would drag. That's why lite is realistic and your neat little machine could do it. No harm I was just giving my knowledge and It is likely very little at that

No worries Bubby, I appreciate your help. I also partitioned 90 GB for this OS. Thanks!