Zorin Os 16 not detecting Grameenphone 3G modem

Hi,

I'm using zorin os 16 (live).
When I'm trying to connect Grameenphone 3G modem, it's not showing anything. How can I setup it?

I'm new to linux.

Thank you.

If you open Zorin App menu, Settings - Then check the Network Tab in the left pane - what options are you given in the Right Pane?

1 Like

Thank you @Aravisian , for you fast response.

When I connect the modem, I got some options like PCI Ethernet, USB Ethernet and mobile broadband. But After 5 seconds the options are gone!!

What to do now?
looking forward,
Thanks,

@337harvey had mentioned something in a previous thread about Some Modems disallow access unless set to allow- Do you have the ability to connect to your Modem Settings on your network and configure such settings?

Yes, @Aravisian .
I can setup the APN and settings to connect with internet.
I'm using windows 10, the modem is working fine.

By the way, the modem needs to install the driver for linux. But when I connect the modem in my laptop, it's not detecting and the driver folder is not showing up. That's why I can't install the driver for linux.

I'm not a native english speaker. I hope you got the point, which I'm talking about.

What to do now?
Thanks

The modem-settings (on the modem) is a suggestion that I note: But am not personally a guru on.
It varies by modem and modem manufacturer.

Are you using the modem for Wired, wireless or Both?
Can you post the full output of

lsusb

@Aravisian , I'm using Grameenphone 3G modem. I've listed the picture of the modem below.

gp-modem-500x500

After connecting the modem in laptop, I've opened the terminal and run the command lsusb .

The output of the command is:

looking forward
Thank you,

Mobile Broadband Station - is that it?

Can you please open "Disks" from your Zorin App menu.
Find your modem listed there and select Additional Partition Options.
Then, Mount options.
There should be a dropdown menu for Identify as - Select that as "Broadband."
Unplug your modem and wait a moment, then plug it back in.
Fair warning, this may take a few tries - but what you are doing is trying to get your system to recognize the modem as a modem, not a storage device. If plugging it back in does not get it recognized - turn off automatic mount in the window above and try unplugging and replugging.
For some, they need to actually reboot in between.
Once recognized it should remain that way.

Sorry for the goosechase - as I said the above may take a few tries.

Sorry @Aravisian !!!

There is no option to mark the modem as "Broadband".
I have added some screenshots below, please take a look.
Thank you,

Step 1:

Step 2:

Step 3:

It's ok- we have just established that the computer is sensing the modem as Mass Storage instead of as a Modem, though. So now we know what to fix.
You may need modeswtich:

sudo apt-get install usb-modeswitch

This is because you need to change the mode for the USB device (modem) to modem instead of storage.
Use (replace _____ with your modem name):

lsusb | grep ______

Note the Vendor ID and the Product I.D.
Making a fictitious I.D. up: 12d4
Replace the fictitious I.D. with the actual one you noted above:

grep 12d4 /lib/udev/rules.d/40-usb_modeswitch.rules ATTRS{idVendor}=="12d4", ATTR{bInterfaceNumber}=="00", ATTR{bInterfaceClass}=="08", RUN+="usb_modeswitch '%b/%k'

Extract the config:

tar xf /usr/share/usb_modeswitch/configPack.tar.gz 12d4(Replace this with your actual ID):4d21(replace this with the Product I.D. you noted above)

Use modeswitch

usb_modeswitch -v 12d4(Replace this with your actual ID) -p 4d21(replace this with the Product I.D. you noted above) -c 12d4(Replace this with your actual ID):4d21(replace this with the Product I.D. you noted above)

@Aravisian , still not working....

As I'm using Zorin Os 16 (Live), it could be a problem?
Do I need to install the Zorin OS 16 permanently to use the modem?

Thank you,

If you followed all the steps above - and if they would have worked on a normally installed edition of Zorin OS; I think they would have worked on the Live edition, as well.
However, it is possible that installing Zorin OS will fully install all files, causing the Modem to be seen. The Live USB is a "Demo" and can never be the full experience. Generally, it is a good guide to see if things work; but not a perfect test, either.

This is the only issue that stopping me to move linux permanently, specially Zorin Os 16.

If I found out that the modem is working fine, I'm going to format full HDD, forget about Windows OS and, start a fresh new journey with linux...

So, tell me what to do now?
is there any log files or something like that? So, that I can share it with you and you can find the problem, what causing the issue.

Just tell me what I need to do...

Thank you,

If you plug in your Modem, does it register as a CD or Mounted Volume? If so, can you browse that volume with your file manager?
IF so, do you see a file named something like:
PCL_Bengal_GP?

When I plug in the modem (Zorin OS Live Edition), nothing shows up. So, I can't browse the volume with file manager.

But, When I plug in the modem in windows machine, I can browse it and I have already collected the file, which you are talking about.

I'm looking forward....
Thank you.

Heh... that is an old modem?

Using a spare USB stick, you can move this to your Zorin OS live Edition. Remember, without persistence, no alterations or settings will stick around between boots of Live USB.
Boot up LiveUSB, plug in the USB stick and transfer the file to your Zorin Home Folder.
Right click the file an choose Extract Here. If that option is not present in the file manager, you can use terminal.

tar -xf PCL_Benghal_GP.tar.gz

Within the extracted directory should be an install.sh file - that is an installer.
You can run that by double click or in terminal with

cd PCL_Bengal_GP

./install.sh

If it lacks permissions:

chmod +x install.sh

Then

./install.sh

@Aravisian , the command is not working....

So, I tried this command:
`

sudo bash ./install.sh

Here is the output of the command:

https://drive.google.com/file/d/1-azpmspz3EnA5Hhf2_8ap_J-7znWnH_r/view?usp=sharing

The application installed successfully but when I double click on the application, it's not starting....

Here is the file: https://drive.google.com/file/d/1h3jFVgYODkBF36mI6ZCok4bOA1Vqyr3l/view?usp=sharing

Looking forward,
Thank you.

`

Can you try:

sudo apt-get install wvdial

Eject the modem, then re mount it and test...
I suspect that you will get a prompt saying that wvdial is already the newest version, though.

@Aravisian , After running the command, the output is:

Looking forward,
Thank you,

How odd... on mine it is:

sudo apt install wvdial
[sudo] password for mech-1:
Reading package lists... Done
Building dependency tree
Reading state information... Done
wvdial is already the newest version (1.61-5).

Can you try this .deb package, instead:
http://archive.ubuntu.com/ubuntu/pool/universe/w/wvdial/wvdial_1.61-5_amd64.deb