Zorin OS 16 not seeing Windows at Boot

I have the same issue here...
When i run sudo os-prober not show windows.

But i can see and access to the disk, from linux

How can i fix that?

I can see the disk

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
loop0 7:0 0 4K 1 loop /snap/bare/5
loop1 7:1 0 55,5M 1 loop /snap/core18/2246
loop2 7:2 0 164,8M 1 loop /snap/gnome-3-28-1804/161
loop3 7:3 0 65,2M 1 loop /snap/gtk-common-themes/1519
loop4 7:4 0 32,5M 1 loop /snap/snapd/13640
loop5 7:5 0 167,3M 1 loop /snap/spotify/56
**sda 8:0 0 477G 0 disk **
**├─sda1 8:1 0 16M 0 part **
└─sda2 8:2 0 476,9G 0 part
nvme0n1 259:0 0 465,8G 0 disk
├─nvme0n1p1 259:1 0 512M 0 part /boot/efi
└─nvme0n1p2 259:2 0 465,3G 0 part /

Have you tried Boot repair?

I try boot from usb but cant do this.

If i run this from zorin, i get this error.

image

This commands not work, but im able to install boot repair.

Got this

Check on BIOS and legacy disabled or enable dont work.

If your disk is NVme, make sure to set the disk controller in BIOS to RAID, not AHCI.

Nvme is the zorion OS.
I have other disk 500gb ssd with windows, and this one i cant get on grub...but can see on zorin

Oops.
Hybrid environment...

It is a bit beyond my knowledge.
I will ask a help from other volunteers.
@Aravisian @337harvey @Michel @StarTreker

3 Likes

Same here.

1 Like

Here's a dilemma.
To boot from NVme, SATA controller must be in RAID mode.
To boot from SSD, SATA controller must be in AHCI mode.

It sounds like a tall order to me.

Is secure boot disabled ?

1 Like

Good point!

This is probably because you installed Ubuntu in a different mode than Windows. If your device came pre-installed with Windows, I will assume it was installed using EFI mode, with fast startup enabled.

You will need to first make your Windows installation work (i.e. boot) again, then re-install Ubuntu using the same installation mode as Windows.

To do that, boot into your BIOS and change boot order, so "Windows Boot Loader" is the first. If you changed from EFI boot to legacy, change it back. If you disabled fast startup you may need to re-enable it (not necessarily, some installations will work regardless).

Once Windows is working, remove Ubuntu completely, by deleting the partition completely, and then remove grub from Windows boot loader.

When you are done with that, re-install Ubuntu using the same installation mode as Windows.

Note: you will need to use partition editing techniques and other methods that require some understanding and experience. Only follow the above suggestion if you know how to use these tools.

2 Likes

Also I would suggest to back up all your personal data in a separate external disk.

1 Like

Well i explain what i do.

I have laptop with 2 disk.

Zorin nvme disk 1
Win11 disk 2 SSD

I Change the disk 1 to a new One and reinstall zorin.

After that the bootloader only show zorin, and cant boot to windows.

When i enter to boot menu show this

Well when you boot from USB a distro or Windows, they Will install in the same way?

I mean efi mode right?

The Zorin 16 installer no longer supports 32bit architectures, so no longer supports MBR. It may be possible to set the bios to legacy mode, and that may resolve the issue. Having the drive set up with both MBR and GPT will cause a conflict when Windows is installed as 32 bit on MBR style disks. The solution that will definitely work is to either reinstall windows as 64bit in GPT style or go without Zorin.

There is a possibility you can find a custom script to boot in AHCI or RAID depending on the OS chosen, but this isn't something you will find easily. I have only ever seen one custom boot script to get an NVMe to work. Another option is to purchase a newer laptop, funds allowing.

3 Likes

I reinstall windows and only change boot order, and now its working.

2 Likes