Zorin OS 16 stuck on startup

After an upgrade and a reboot, I have had the following issue:

I turn on the laptop and all I see is
"Zorin OS 16
. . . ."

Cntrl + alt + [1..6] non work.

It seems like it is completely frozen.

I also ran Zorin from a boot Usb and tried a boot repair. which was done successfully but still it remains stuck with the text "Zorin OS 16 ...."

Can someone help with this ?

What graphics card do you have?

Its an asus GL752VW laptop that has a an Nvidia 960M gpu and an integrated Intel GPU as well.

Can you you try tapping the esc or tab or left shift key at boot in order to pull up Advanced Options For Zorin and select an Earlier Kerneal and then try booting up normally. See if that allows you to reach the desktop.

Holding shift should've worked but it didn't load a grub menu. Although I'm sure it worked previously before I had problems..

However... holding 'esc' key loaded a grub prompt/terminal.

I typed in "normal" and after I hit enter and tapped esc again, the grub menu showed up.

Both kernals below still encounter the problem.

After loading a kernal on recocery mode and fixing packages...

I can now cntrl + alt + f2 to login on tty2

You might try entering the recovery menu, drop to prompt,
then

sudo nano /etc/default/grub

Change:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

exit and SAVE
Then run

sudo update-grub

Try booting normally.

I have applied the changes you mentioned, it goes back to freezing with nomodeset. it wont allow me to login with cntrl+alt+2.

without nomodeset, i can log in to terminal tty2

I do believe though that it has something to do with gnome.

I think somewhere previously before the problem, I typed in apt -get autoremove and it took out gnome with it.

also because during the boot... I do not see the Zorin Logo anymore when it is starting up, and now it only shows in a terminal style.

smh... all I had to do was sudo apt-get install gnome

well.. thanks for you guidance. I managed not to reinstall an OS today.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.