Zorin OS 17.1 Lite online video playback stuttering/teleporting

I've decided to upgrade from Zorin OS 16.3 to 17.1 (both Lite versions), doing a clean installation. After testing it for a little bit, I've found a problem, the thing is that, while trying to play videos on Firefox, it starts to frameskip/stutter/shake, something that didn't happen on the previous version. I don't think that's a performance issue, because my CPU usage goes around 40/50% while playing, RAM consumption is pretty low, and in some html5 players (for example, YouTube) this bug doesn't occur. I've tried disabling hardware acceleration on Firefox, but the problem persists. Any clue of why this happens?

PC Specs
CPU: AMD A10-5800k
RAM: 2x8Gb
Storage devices: 240Gb SSD WD Black (SO located here) and 160Gb HDD WD Caviar (Backup only)

Welcome to the Forum!

Let me ask a few Questions:

Do You use Firefox as a Flatpak Version?
Is this Behavior only on one specific Video Service (a specific Streaming Service for Example)?
Did You activate in the Plug-in Menu the Widevine Decryption Module and the Open H264 Module?
Did You installed the Codecs from the Software Store and the ubuntu-restricted-extras Codecs?

The question on Firefox flatpak being used is somewhat irrelevant as new installs come with flatpak (unless different with Core), and OP might not be aware of this.

2 Likes

But I don't know if @D_S maybe has changed to the .deb or Snap Version after the Installation. So, I asked to make it clear.

1 Like
  1. I used the version that comes with the OS, I have no idea if it's the flatpak one or not.
  2. Happened to me in a few players, like JWPlayer, it's not specific because it occurs in other video services too, but also there are services which this problem doesn't occur, so it isn't a global thing either.
  3. No, I have no idea what's that.
  4. Probably not, it's a clean install, with third party programs and drivers, but I've not touched any of that, I've let the installer to "do its thing".
1 Like

Yup, I didn't reinstall Firefox at all, I've been using the preinstalled version.

1 Like

Okay, thank You for the Info's.

First, You could try to install more Codecs. For this open the Terminal and type sudo apt install ubuntu-restricted-extras and try it with the Videos again. When You install it You must accept a Licence Agreement because in the Package are Microsoft Fonts included. I write that so that You don't be surprised by that.

A 2nd Place is the Software Store. There You should find a Category called Codecs. There You can install other Codecs too.

Because of Point 3: I think that is because of the Widevine Decryption Module. That is easier that it might sounds. Open Firefox and go to the Add-ons and Themes Settings. There You go to the Plug-in Tab. I looks like this:

Look that these two Things are activated. Click on the three Points Button at the right Side to control it.

Another Option is to try if it runs with the Firefox .deb Version better.

2 Likes

Installing Firefox's .deb package (or using Chromium) did the thing. Thanks.

1 Like