Zorin OS 17.1 update: Telegram stopped working

I uppdate to 17.1 and the Telegram desktop app stop woring!

What package format did you use to install it?

The .deb format from the PPA is much more stable:

sudo add-apt-repository ppa:atareao/telegram

sudo apt update && sudo apt install -y telegram


Please note that this PPA is unofficial. Telegram provides a tarball, Flatpak and Snap of their desktop application that they officially support and update.


I use telegram AppImage, it's up-to-date, but sometimes suddenly it closes, It has problem with newer version, I didn't have problem with older version.
Check this package, maybe it works for you

I don’t remember which distribution (Zorin, MX, Mint, Fedora), the Flatpak has worked great. I am sure I have used the Debian version and it was fine with maybe a few missing features but it worked very well for me. Both an Intel and AMD machine. Telegram is awesome. Too bad Telegram is not encrypted end-to-end by default but I don’t use it all the time so it is good enough for me. I just like it works on all devices and you can send full resolution images from any device. Let us know what the solution is.

EDIT: Neglected to mention… make sure you haven’t deleted any dependencies that may rely on native packages. I have seen posts in the past on other forums whereby users remove packages that another application needs.

Thank you Aravisian, greit, that funktion for me. :+1:

1 Like