Zorin OS 17 Invisible Cursor After Boot

I have 3 virtual machines that are: Zorin OS 17, Zorin OS 16.3 Educational Lite, and Tuxedo OS KDE. They all have been working fine. I install as little as possible and run updates as soon as I can. I don't like messing with anything in the system / command line. Any quirks seems to typically get worked out without intervention through eventual system updates.

About a month ago my mouse cursor started being invisible and would randomly become visible on the login screen. It has occurred more and more often through the month with no updates fixing it.

Within the last week or so it started being invisible through the login to the desktop as well. The best I can tell is that the cursor is bugged until it crosses a textbox. That interaction fixes the cursor until the next boot. I am not 100% certain though. I don't know what to look for in the system log viewer. The behavior is shown at https://imgur.com/a/SH41RZI .

This doesn't happen on any other virtual machine and never has in the 5+ years I have used Linux as a hobby with over a dozen different distros. I decided to see if there was anything I can do or how I should report it. Thank you for your help.

Does still happen when you log in to the X11 session (Ubuntu on Xorg) instead of Wayland?

Thank you for your help. Switching to X11 on the login screen doesn't fix that portion as seen in the image. The cursor is still invisible as I didn't move it away from the gear menu.

Logging into the session by typing on the keyboard and not mousing over a text field (to keep the cursor invisible) seems to fix the cursor after login by making it visible till reboot. How do I force the login screen to use X11?

Once Xorg is selected, it is automatically used until you change it back to "Zorin Desktop".

Thank you for all the help Topaz. I want Zorin 17 to be my main OS without problems.

The login screen still has the invisible cursor bug on a fresh boot. It shows that Xorg is selected when I check each time.

Logging into the desktop with Xorg seems to make the cursor appear on the desktop and potentially fix that half of the bug. I tested it a few times. Anything else I should do/try?

Zorin OS 17 defaults to Wayland, unlike all previous Zorin OS editions.
In Wayland, the vanishing mouse cursor is not uncommon due to bugs between Wayland and GDM and Mutter.

Usually, this is resolved by using the standard Xorg desktop instead of the still experimental Wayland.

337harvey Community Leader

You could try to reconfigure GDM3.

In terminal: sudo dpkg-reconfigure gdm3

Provide your password, then, when it finishes,
reboot to test.

Thank you for the suggestion. It didn't seem to fix it though.

Aravisian Community Leader
Zorin OS 17 defaults to Wayland, unlike all previous Zorin OS editions.
In Wayland, the vanishing mouse cursor is not uncommon due to bugs between Wayland and GDM and Mutter.

Thank you for the information. What do you recommend I do to help it get solved for myself/others? I will use the workaround in the meantime for the desktop at least. Having Xorg selected at the login screen doesn't seem to fix the login screen portion.

I don't believe Xorg or Wayland are running until after login. GDM appearance, including cursor, is set somewhere else. Could be hard coded?

There is a utility called gdm-settings to customize GDM login screen (including cursor), but many of the settings it showed no longer can change. Cursor was changeable in Zorin 16, I believe. I don't know about 17. Need to test that.

The mouse should be governed by the motherboard first, then the U.I. O.S. takes over at init.
@Cay, what make and model of mouse are you using?

I wasn't able to locate gdm-settings through apt or the software center to try.

I use the built-in touchpad for most of the work. It is the one that comes with the Dell XPS 15 9570. Windows device manager seems to hint at a Synpatic touchpad and it works without issue as far as I can tell. It seems challenging to see technical data for it.

xinput list shows the list below.
xinput list

Zorin 16.3 Edu Lite shows this for the input devices.
16.3 mouse list 01

I can do a bug report if someone could guide me on where to go and how to gather the relevant tech info.

I can confirm that mousing over a text field on the login screen triggers something that refreshes/fixes the mouse for that session to then be visible. It goes back to invisible on the next boot. Still isn't a problem in the other distros. Thank you for all the suggestions.

Zorin OS 16.17 comes with server-xorg-input-libinput

Have you tried installing the synaptics driver?

sudo apt install -y server-xorg-input-synaptic

sudo apt install -y xserver-xorg-input-synaptics
had no effect unfortunately. It still takes mousing over a text field in the login screen to make the cursor visible even after installing all updates available in the update manager as well.

Try the Search only with gdm. Then You can find it:

It is the first One.

Thank you for your help. I was able to find GDM Settings and changed a couple of settings but it didn't seem to fix the invisible cursor during login.

I changed the cursor to something other than Adwaita, applied the settings, then did a full power down and startup as I have been.

I also tried changing a login setting to see if that would cause an update to the login screen configuration wherever that is stored. The cursor was changed back to Adwaita as it had originally been. The machine was powered down then back up and the login screen cursor is still invisible.

Yeah, GDM-Settings has its Problems with the newer Gnome Versions ... You wrote that You use it in a VM. Maybe this is the Problem. Is it possible for You to install the System and look if You have the Problem then too?

I wonder the same. It looks more to me like the cursor is not being initialized until used.

1 Like

Yeah, I don't know. My other current 2 VMs (One being Zorin OS 16.3 Educational Lite) do not do it. My past VMs (roughly 13, including some with Gnome) have not done this and never have over the years. Thank you.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.