Zorin OS 17 Pro won't boot after Intel RST enabled in BIOS


  • Installed Zorin OS 17 Pro in a dual boot environment.
  • Working perfectly fine until today.
  • I noticed in Windows 11 that my previously existing Intel Optane Storage Raid 10 array had an error on one of the drives.
  • I researched a while and finally determined that somehow the Intel RST Feature in my Asus Prime Z390-P Motherboard was turned off (??)
  • I turned it on in BIOS and rebooted Windows.
  • My R10 array was back and nominal
  • Tried to boot to the Zorin OS 17 UEFI partition and it failed.
  • Boot seems to be puking trying to determine what that R10 array is.
  • I tried troubleshooting by booting the Zorin OS 17 USB Key and following directions to repair the boot using the system tools. It failed and wrote a Boot Record to https://sprunge.us/3Q4kC1

Any ideas before resorting to reinstalling Zorin?


Welcome! :sunglasses:

Do you have RAID enabled in your BIOS settings?

Take a look; if so, just disable it or use the AHCI disk mode, then try reinstalling :+1:

RST or Rapid Storage Tech. is good, just doesn't like Ubuntu / Linux.

AHCI would be 'regular' SATA disk mode, still high-speed though!

Yeah well, I want to use RST for Windows 11 for my 4 drive Raid 10 array.

Oh I get what you're saying - I'm not familiar with it but, there are workarounds for that setup.

This may be helpful but, again, not familiar with it myself.


Well, I guess that answers that.
Boot errors:

And trying to reinstall with RST enabled:

Now I've got to see if I can safely disable RST without fubaring Windows. :smiley:

1 Like

So I finally resolved the issues and can now dual boot again. My Windows 11 got fubared when I switched to AHCI from RST even thought I was not booting from a RST volume :neutral_face:

Booting a Windows 11 USB to try and repair did not resolve the inaccessible_boot_device error I was getting on the Windows partition.

Finally found a solution on superuser.com that worked.
ssd - How to change safely storage controller mode from RST to AHCI in Windows 10? - Super User


Well dang! Not so fun to hear, but is good you got it going :+1:

I personally have not used any RAID since SCSI days :smirk: and even that was a headache! At least with SATA you don't have to terminate at the end of the chain nowadays :grin:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.