Zorin os bootloader bug

So, I use zorin os 17.1 as my daily driver. I tried removing the windows partition, basically removing the entire Windows OS, then ran update grub, as I thought it was a good idea. But I encountered a bug when every time I turn on my computer, instead of the boot sector menu which should be showing up, what was shown was what appears to be a blank screen of darkness lying for 10 seconds, untill booting up to the Zorin os system. Does anyone have a solution?

So it does eventually boot. What do you mean by "the Zorin os system"?
Does the grub menu screen appear after 10seconds, or some other Zorin screen?

Does the terminal command efibootmgr show Windows OS Bootloader?
It may be hanging on trying to locate Windows.

You can then use efibootmgr to delete the Windows Bootloader.
Note the last number of the boot ID number for Windows os, then run the following command to remove the bootloader ***replacing the # with the actual number:

sudo efibootmgr -b # -B

For example, if Windows is listed as 0001:

sudo efibootmgr -b 1 -B

No..I mean a black screen appears for 10 seconds before booting up into the Zorin os system

The grub menu doesn't appear at all

Help, when I type efibootmgr, it says my computer doesn't support efi

When there is only Zorin installed it doesn't show the grub menu by default, it just boot directly into the os. About the 10sec darkness I'm guessing the GRUB_TIMEOUT value has not set to 0 in the grub configuration file, after you removed Windows.

  • Open terminal and run:
sudo gedit /etc/default/grub
  • Set the GRUB_TIMEOUT=0
  • Save the file and exit the editor then run:
sudo update-grub
  • Reboot and Check

OK for an experiment, but setting GRUB_TIMEOUT=0 is not considered such a good idea, as you will not have a chance to change boot choice to Recovery mode in event of a problem.

1 Like

You can get the Grub menu during boot time:

  • In legacy BIOS - Using shift key

  • in UEFI - using Esc key

  • or press n hold ctrl+alt+del during boot up

In my default (& currrent) Zorin installation GRUB_TIMEOUT has set to 0 by default. I never changed it and I use the ctrl+alt+del to get grub menu when I need it(very rarely).

Does this really do anything?

But can I at least do this trick?

The minimum timeout for any journaling system (NTFS, Ext3/4) needs to be 5 seconds. Anything less can corrupt the bootloader.

1 Like

You can try that. If it doesn't work then you can discard the changes you have made.

So 5 secs is enough?

Yes, 5 seconds is enough.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.