Zorin OS broken after NVidia 530 driver selection/installation

Try enable it and see if it recognize it.

It doesn't.

By the way, under Software/installed everything is blank.


It's because the software center can't load the meta/index packages due to no net connection.

Maybe back up your stuff and reinstall the OS?
If No, we could see if @Aravisian has any thoughts about this one when he comes online.

1 Like

Yes, I guess it's the best to install it new. I've already backed up my stuff.
Too much has broken. Not just the graphics driver, but the network, the sound, and even the USB keyboard.

Zorin OS has been great so far. But I'm worried about the system now. There is an insecure feeling, that the system suddenly breaks with something as normal as an offered driver version update.

Well, I can try to replicate it. If it breaks again, then the developers can take a look at it.

I never seen or heard that installing the restricted driver would wipe network,sound and keyboard. But there's a first for everything.

The Nvidia driver is restricted/close source that's why it may break the system. That's why it can be hard to implementing the driver for the devs. I'm a Nvidia guy myself and love the performance it has on Linux, but the close source driver can be a pain in the rear.

Yes, for me it's the first time too. :smiley:
Thank you for your time and help. I'll get back tomorrow and tell you if I was able to replicate the error.

1 Like

Being that you are using the 1060, I would stick with the 525 driver since it worked and gave you all of the functionality that card can handle. The newer drivers add feature support and new firmware, neither of which apply to you.

I feel there is a different issue than the driver though. With the network card, audio and gpu failing it sounds more like the motherboard or disk is going. Check the drive in gnome disks. As long as there aren't too many bad blocks/sectors it should be fine.

Then I'd check the motherboard.

@Zornaut Just a thought. I wonder if a kernel update has occurred. Have you tried booting a previous Kernel via Zorin Additional Options.

1 Like

Hi, I have installed Zorin OS and now the NVidia 530 driver is installed from the beginning. Everything seems to be working fine.

Then the system makes a regular update. And yes I guess there was a kernel update 5.15.x.

After restart, on booting:
error: attempt to read or write outside of disk
Kernel Panic: Unable to mount root

And after a few attempts:
no such partition
You need to load the kernel first

So the 530 driver and a newer Kernel version in combination may be the issue?

I installed Zorin OS again. I checked the installed versions first:
Kernel: 5.15.0-71-generic
NVidia: 530

This time I didn't do a system update. But it's the same error after rebooting. So now I can't install Zorin OS with default settings.

2nd Update:
I installed Zorin OS and changed/installed NVidia driver to 525 after first boot.

But now the same error appears. Can't boot or use it anymore.

Ok, my final Update:
I installad an other Ubuntu based Distro. It starts with Kernel 5.15.0-56-generic and xserver-xorg-video-nouveau driver.

I select and installed NVidia 530 driver.
Restart and everything works fine.

Then the system Update with a Kernel update to 5.15.0-71-generic.
After that I restart and... everything works fine. PC boots absolute normally.

So, I'm sorry! I don't know what the sudden problem with Zorin OS and my PC is. But even a new installation doesn't seem to help.

It sounds like a disk error occurred.

When you switched drivers, It either ran out of space in the block or it corrupted the entire block.

1 Like

The current problem is that I can't install Zorin OS anymore. No matter what I do, after the first reboot (after the first start), I get the error. I've already invested a lot of time and don't have more time for it at the moment. The other distro works fine, so I'll continue to use it for the time being.

I don't know if I can still help the developers in any way. There seems to be some other things causing the error. Because with NVidia driver 530 and the kernel 5.15.0-71-generic it still runs in another Ubuntu based distro.

The last attempt would be to install Zorin OS without driver search and use the X.Org-X server driver. But is this of interest to the developers? If yes, I would give it a try next week.

My specs:
i7-4790, Mobo: Asus H97-plus, NVidia GTX 1060 6GB, M.2 SSD 1TB

Sadly, there isn't any solution for this problem.
Can't use Zorin OS with my rig anymore. The only thing I can do is to wait for a new release version and hope it will work.

My solution now, was to use another Ubuntu based Distro.
With the same Kernel and NVidia driver it runs without any problems since one week.

I hope I am one of the few who has had these dramatic problems with Zorin OS and that the problem will be solved in the future.

Thanks for the quick replies!

I have 1030GT and drivers working on mint.
Device-1: NVIDIA GP108 [GeForce GT 1030] driver: nvidia v: 530.41.03
Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
Display: x11 server: X.Org v: driver: X: loaded: nvidia
unloaded: fbdev,modesetting,nouveau,vesa gpu: nvidia
resolution: 2560x1440~60Hz
OpenGL: renderer: NVIDIA GeForce GT 1030/PCIe/SSE2
v: 4.6.0 NVIDIA 530.41.03

Somehow I doubt that it's Zorin related.... That doesn't make much sense, logically. As was implied, all the other problems you're experiencing with peripheral equipment and services have to be related to a kernel issue, but to say that the kernel issue is specific to your Zorin installation doesn't quite make sense to me because there isn't much evidence pointing to that suspicion.

  • It occurs to me to ask if maybe you just had some bad luck?
  • Maybe you installed/reinstalled the OS as encrypted.
  • It also occurs to me to ask if you've ensured Safe Boot was disabled in BIOS.
  • There might also be a Software Guard at the BIOS level that could be affecting your install.
  • Multiple corrupted installs due to disk read issues (implied) and incorrect permissions or bad sectors - pointing to a requirement to reformat and start with a new partition scheme.

I'm glad it works with normal Ubuntu install and nouveau, but that may also have been related to something other than Ubuntu or the kernel it uses; regardless, I think it (Zorin) deserves another chance at install with you carefully moving through the process and following all accepted suggestions for installing Zorin - found here in the forums as tutorials and other forum posts.

Also, consider taking advice from good people like @zabadabadoo and @Aravisian; their suggestions come from a place of experience. Try another kernel when loading Zorin. Try figuring out if you have corrupted disk sectors and do a disk check. Consider that you don't exactly need the 530 driver, look at what it's supposed to give users and determine if you are in that targeted group; if not, no harm in staying at 525 as @337harvey suggested - especially if it worked fine and gave you no issues.

1 Like

If he used a command sudo apt remove --purge nvidia* it crash operating system Zorin.
I know because i tried and have experience with that unstable Zorin.
Reinstall and using with Xorg but not Wayland.
With this nvidia 530 must be something wrong because my games are crashed with that newest version.
Propably Nvidia isn't best for linux. Idk if AMD Radeon will be better choice.
That is neverending journey with drivers can working but not must working like should.

Ok, summarized my approach:

  1. I start Zorin OS via USB image to live desktop.
  2. There I delete everything on the SSD with gParted.
  3. Then I start the installation.
  4. After successful installation and first reboot everything works fine.

But when I reboot from this point, no matter what graphics driver I selected and installed, I get an error when booting. I tried every graphic driver with the same result. And I tried to reboot without any update, unsuccessful.

The only thing I haven't tried yet is an installation without driver search checked at installation.

I haven't any secure boot or anything else, and nothing has changed from the first Zorin OS installation, that worked absolutely flawless for two weeks.

It's also funny that the first reboot always works.

Reported bug that kernel 6.4 doesn't work with 530
"Install older"
And they closed

As a solution

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.