Zorin OS broken after NVidia 530 driver selection/installation

Hi, I have a fresh installed Zorin OS 16.2 Core.
I have a NVidia 1060 and selected the 525 NVidia Driver.
So far so good. Everything worked fine since 2 weeks without any problems until...

I selected the 530 NVidia driver at the additional driver menu. After Installation and reboot this happened:

  1. My screen resolution is only 1024x768 and I can't change it
  2. sound card is gone
  3. network is gone
  4. can't type anything on my keyboard
  5. NVidia xServer settings is blank

I can only use my mouse, so I selected the 525 driver, but I can't type the needed password with my keyboard. It's not working.

So I go to grub with shift pressed on boot and started the recovery mode. But then I stuck again, because the keyboard isn't working in the select screen.

Edit: Ok, I managed to copy and paste my password out of a text file. But now the 525 driver can't be installed, because the network is broken too.

What can I do? Can I repair it with a live usb stick?
I maybe can save with my mouse working all my stuff, but I don't want to use Zorin OS anymore, if it can break so easily and fast with an official and tested driver. So it would be nice to know, what happened. Or better, I can still fix it.

Do you have access to an external wire keyboard you can plug into your computer?

My keyboard is wired. But I take another keyboard and plug it into front usb.
It's working!
But the internet connection Is broken too since the driver update.
I try the recovery mode again...

...ok, I'm in the recovery menu.

You could purge Nvidia driver from your system, by:

sudo apt remove --purge nvidia*

then it should pick up the open source driver 'nv'.

Then install driver 525 that worked.

Ok, where can I type that?
I started the usb live demo.
Everything is working fine there.

When booting to your system (not live USB) and you are greeted by login screen, press [ctrl]+[alt]+[F4] it will take you to the TTY/CLI. Here you can purge the driver, when done:

sudo reboot

Thanks for your reply.
I executed the above command. But I have the same problem.
NVidia driver isn't installed.
Currently the X.Org-X-Server driver is selected.
How can I reactivate my network?

How do you connect? Ethernet or wifi?

See if this commanline option works for you:

Ethernet. Everything on this desktop PC is connected with cables. :wink:

Added link to youtube video whilst you were responding! Check my previous post with video link.

Do you have access to a mobile to hotspot?

Unfortunately, that didn't help.
Network is still gone, sound is gone, graphic is gone.
How can this happen? Nothing went wrong on installation.

Well, I don't have Wifi on this computer.
Ethernet is working flawlessly with the usb boot Zorin Live Demo/Installation.

Oh right... my bad.
Did you try to install the 525 driver, it packages may still be in the system if not cleaned.

At this point if it was a fresh install that is messed up, consider re-installing as it would be faster than debunk what went wrong and then keep to the 525 driver.

I tried to reinstall 525 at first, but it throw out an error, it wants a network connection.
And there must go so much wrong, because Ethernet and audio is missing too.
Strange that my USB keyboard doesn't work either.
A worst-case scenario!

What does it say when:

sudo lshw -class network

Ethernet controller
RTL8111 PCI Express Gigabit
ID: 0
Version: 11
Do you need specific data?

I just want to see if it's detected.
Can you to

sudo apt install r8168-dkms

The package might still be on the system. Else I don't know what to do as it requires internet connection to do so.

It may be on the USB. If you enable the source from the USB in your software repositories.

Unfortunately not, I get the message: some archives could not be downloaded.

Ok, I try it from the usb stick. But in the options I can only add a cd-rom?