Zorin os Browser Changed its home screen

Did they changed starting page of browser in zorin 17 or it's just bug in my browser

Before zorin 17

Firefox used to start from https://start.zorin.com/

But now it start normally like any Firefox

Here is screenshot

In zorin 16 version

In zorin 17

Not sure. I removed Firefox. It is now a Flatpack. Did you change the Home location for Firefox? You can use the old location as HOME for Firefox. It does NOT seem like a bug.

I personally did not like the old version, as too Google-centric for me. If you want privacy, the best browser is unGoogled Chromium. The best search engine for me is mojeek.com as it does not censor your searches, and if you don't get what you want from Mojeek it comes with alternative search engines, my favourite being Brave search engine. I then get rid of Google, Bing, DuckDuckGo, eBay search engines.

1 Like

In firefox type:

about:preferences#home

Then change to Home landing page and the Firefox Home Content (if any) that you want to appear there.

1 Like

Because on Zorin 17 Firefox comes by default as Flatpak there are only the Firefox Standard Settings on and no Adjustments I guess.

How does it shows on your Firefox browser. And what zorin version are you using

How does it shows on your Firefox browser. And what zorin version are you using.

I use Firefox directly from the Mozilla Repo (relatively new). And that is the normal Standard Firefox Look without Adjustments from others.

I don't know if You want to try to add the Repo (which I would understand; I didn't done it directly, too) but Mozilla wrote a Step by Step Guide. Maybe You want to take a Look on it: