Zorin OS Core 17.1 - very poor performance - laggy, freezes, downloads trickle slow

I am hoping someone can help.

I had a perfectly functional arch linux installation on my laptop (Huawei MACH-WX9 - 16GB, Core i7, SSD - so plenty of hardware power.

It's worth noting that the Zorin live "cd" worked just fine.

Install was painfully slow. Once installed, a bootup is about a 6m50s ordeal. Thereafter any new application launched takes a few minutes before launching. Once it has been launched then closed, a second launch is quicker (some cacheing?)

Any software installs are excruciatingly slow (I have a good internet connection, so that isn't the bottleneck)

The UI "seizes up" at random times - sometimes for a few seconds, other times up to a minute. Resources on the machine appear plentiful, so this is a puzzle.

Going to try new nvidia drive as a last resort, though the installed one is pretty current.

Any other ideas??

Thanks in advance.

1 Like

Since Live USB works fine, I suspect it is a driver issue. The size of the UI is odd, suggesting a graphics problem. Newer is not always better for Nvidia drivers, and sometimes it can be tricky. Please see the post below to clarify more information about your hardware. It will lead to further help.

1 Like

This also sounds a lot like the installation corrupted.
If the LiveUSB worked fine, but the bare metal install is not behaving the same way, it is a good chance that something went wrong with the installation process and you do note that it was painfully slow to install.

Installation of Zorin OS, when it goes slowly, should take no more than about 45 minutes and normally, not even that long.
If this was me, I would set some time aside and install Zorin OS 16.3 and test that performance. Then do a fresh full install of Zorin OS 17 and test the performance.

That may sound goofy, but it is likely to get all the systems and files in place.
Sometimes on an initial install, the remaining data on the drive interferes with the new because it is not actually erased, just the markers removed and some data gets overwritten only as space gets used.

This occurs on Windows as well, but since the user is usually reinstalling Windows, the FS autorepair is able to replace and reorganize so it does not even get noticed. And this is just as true on GnuLInux.


Thanks - will do

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.