Zorin OS does not detect Windows 10

Hello,
I just recently tried out Zorion OS and I enjoyed my experience with it. So much so that I finally decided to gradually migrate from Windows 10 to Linux. For now, I want to have Zorin alongside my Windows 10 installation so I want to have it as a dual boot option but, during the installation process, Zorin does not detect windows 10 at all. I have Fast Boot, Secure Boot, and bitlocker all disabled and Zorin still does not detect Windows 10.
I tried looking up online but nothing useful came up.
What can I do so that I can install Zorin nicely along Windows 10?

1 Like

How many partitions do you have on that Win10 machine?
Maybe post a Gparted screenshot of your partitions here.

How did you try to install Zorin, did you use "Something Else" method?
Have a look at this: USB boot install

Which flavour of ZorinOS are you trying to install e.g. Core, Lite etc?

Is Zorin installing, but you are not seeing a grub menu on boot?

Here is a screenshot of my partitions:


I put that unallocated 100GB aside for the Zorin Installation.

No I did not proceed with the installation. The installer said that no other Operating systems have been detected and I did proceed further from that.

I'm installing the Core version

1 Like

So you were planning to put Zorin Core in the Disk 0 97.66GB "unallocated" partition and have existing Win10 on Disk 1.
I see what else I can dig up.

1 Like

Yes, exactly.

I was going to suggest you look at this, but I see you have already found it.

I also suggest a look at @carmar 's post here, also the associated links he posted there.

There is an outside chance this thread may offer some clues:

Also from the old Zorin Forum:
https://zoringroup.com/forum/4/15355/

Yeah, I have already read all those.
But I actually found a solution to it.
The problem was that the SSD would not initialize without the SATA mode being set to AHCI in the bios settings.
After turning that on, the installer immediately recognized windows 10 and the windows bootloader.
I found the solution here and I followed the steps. The installation went smooth and without problems. It's probably good to mention this in the FAQ and or the installation guide, so that others would know how to tackle this problem.
I hope this'll be of help to others as well.

3 Likes