Zorin OS does not return after updating the system

I built a computer and installed Zorin OS 15 Lite (at the time). It always worked perfectly.
Last week I had the idea to install both (Lite and Core) with shared /home. I did this on all my notebooks successfully.
But on my main work machine, the one that was running Zorin OS Lite 16 (I had already updated) something very strange happens.
Every time I've tried, and I've tried more than 3 times in different ways, the same thing happens.
I installed the system, it restarted perfectly.
I download system updates, and after restarting it gets a black screen. (monitor on, but no image)
I installed Core and Lite (with /home shared), only Core and only Lite. Every time the same thing happened.
After updating the system, I reboot and it doesn't come back.
Has anyone seen this happen? Do you have any idea what it could be?
Thank you in advance for your attention : )
PS: I already updated the BIOS

What video card are you using?

Thanks for the answer : )
NVIDIA GeForce GT610

The 340 driver should work well on that card...
Which driver are you using currently?
You can check with Software & Updates > Additional Drivers tab

I'll have to install the system again, otherwise it won't come out of the black screen. I need to boot from the pendrive and install the system again. I will check it out. In both versions, is it the same driver? (Gnome and Xfce)

Yes. The driver is not desktop dependent.
Before you try reinstalling... you might boot into Recovery Mode.
Tap esc or tab at the motherboard splash screen until you see the Grub Menu.
Select Advanced Options for Zorin
Then Recovery...
Arrow key to Enable Networking then once enabled, back up to the recovery menu.
Arrow key down to Drop to Prompt
Hit enter
Now remove the Nvidia drivers You may want to copy this onto something you can easily read and type out);

sudo apt-get remove --purge '^nvidia-.*'

Install 340 and test booting normally

sudo apt install nvidia-340

I'll try to install again by changing the drivers. The motherboard splash screen does not appear for me.

1 Like

It was a suggestion that may have been easier for you- if a reinstall is easier- that is just as good. :wink:

Installing again as soon as possible, I'll give you a feedback. Thanks so much for the help. :+1:

Apparently, it didn't work. Should I try the 390?

So far it worked. : )

1 Like

Marked the solution - but you can return and unmark it and post if the solution fails after further testing.

1 Like

Apparently I'm having the same error again.

It only occurs after updates?
I wonder if you block the culprit update, if it will prevent the error...
I suspect locking the Kernel or the Graphics driver.
The apt-mark hold command can be used to stop a package from updating.
apt list -u will show which packages will be upgraded... You can use that list to identify individual packages.

Yes. After choosing the driver I restarted the computer. It worked normally but once I download and install the updates. After restarting it does not come back. The screen goes black and does not show the motherboard splash screen. How do I get to the terminal then?

The terminal is accessible using the App menu or the fast Keyboard Shortcut ctrl+alt+t

I have an appointment I am heading out to shortly - expect late replies.

I think I expressed myself badly. I know where to find the terminal. : ) But the computer is not booting the system.

Oh I see... you need the recovery menu- as covered above - to access the recovery terminal.
I believe you mentioned not seeing the grub menu at all..

Yes. The screen goes black and nothing appears. If in the first few seconds I press F12 it shows the boot menu. F2 goes to BIOS. Other than that, I don't know what can be done.

Have you yet tried Nomodeset parameter?

sudo nano /etc/default/grub

Find line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and add the nomodeset parameter:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Tap ctrl+x to exit which will prompt to save- tap y to say yes to save, then the enter key to save and finalize the exit.
Now you must run

sudo update-grub

Reboot and test...