Zorin OS doesn't start anymore [error aufs_sfill_super & overlayfs: missing lowerdir]

Hello,

Yesterday my Zorin computer had a crash. It was completely frozen and I wasn't able to do anything with the computer. I left the machine running hoping that it would self defreeze but no it stayed this way even after the whole night.
So I had no choice but to turn it off using the ON switch of the computer. Before I restarted the computer it locked itself (screen got black) and when I tried to move the mouse or press key on the keyboard nothing happened the system didn't wake up.

Now when the system is starting I got the 2 following message:
aufs aufs_fill_super:918:mount[1415] no arg
overlayfs: lissing 'lowerdir'

I don't know what happened but the system is completely done and won't restart (when I am prompted the 2 error message my keyboard num LED isn't even lit).

How can I fix that error and make my computer working again ?
I tried to use the USB key I used to install Zorin but didn't see any repair option like it exists for windows.

I am a total new user of Ubuntu based system because it's my first time using a machine with an OS like this. So I am completely lost on how to fix this issue I'm facing.

I guess reinstalling would be the best way to fix it but I don't wanna lose any data.

1 Like

If you decide to reinstall, you could boot from installer USB to run Live session and copy the content of your home directory including some hidden files (shows with ctrl +H).

Interesting. That message usually means that Root is full.
What size is your hard drive?

Have errors been racking up in logs?

Also, are you using Nvidia Graphics?

1 Like

Try the solution from this forum:

It recommends a reinstall of the kernel, check drive space and possibly change video driver.

1 Like

Ok thanks for the quick replies guys.
The computer I'm using doesn't have a dedicated graphics card but is using the integrated graphics from the CPU (intel HD graphics).

Before this big crash (it happened while trying to unzip RAR file I created on a NTFS drive, obviously I got an error and the system completely broke after that, UI not responding etc.)

The OS drive had like 15 or 10 Gb of space left so I don't think it's a space problem. Maybe a file got corrupted I don't know.
Recently I also got a brief power outage but my computer worked just fine after that.
The OS drive is a 128Gb SSD the brand is Samsung.

Ok I have a HDD connected to this computer so I could transfer the file and then reinstall everything.

When you say reinstall the kernel does that mean a full OS reinstall or not ?
I had a python script that did check periodicaly for data on a website every 30min and log the data back in a TXT file on the OS drive so maybe something happened during the write process of that file.

1 Like

I cannot agree. Your disk may be at 90% capacity.
A 128 gig drive filled to about 10 gigs left free is stuffed to the gills.
Windows places any new data into any closest available spot. Linux works differently.
Linux allocates a reasonably sized Block of Space for programs, data and software. These blocks include allowing extra free space within them to account for growth- updates and upgrades increasing that packages size.
This is why Windows must be defragged and Linux never needs to be defragged; because Linux does not fragment. (This is also why Linux can show when a drive is failing long before Windows shows the symptoms.)
EDIT afterthought: Also, please keep in mind space allocated for Virtual Memory as well as processes run and purged in init that take up data space but do not count toward your 'used disk space.' Your drive is definitely filled. /end EDIT

Looking at the link 337harvey posted, there are tips for booting into the Recovery Prompt and clearing out some space. I would try that first and see if a system cleaning can get you booted up. After that, you might clean out any data in /Home that you do not need anymore.
If you can do this - make Back Ups of your data!

There are many threads on this forum suggesting Cloud Storage. Mega is one of them.

You may consider getting an External Storage Drive or large USB stick.

No, reinstalling the kernel is only in regards to the kernel, not the entire OS.
I would not hedge my bets on kernel reinstall as the solution in this case... In fact if your drive is too full, trying to add more APT Cache could recreate the problem and crash your computer.
I'd clean up the drive as much as you can, first.

1 Like

Ok I used the USB stick to boot into the live CD version of Zorin.
But it doesn't let me delete or cut and paste file because I don't have the right permission to do so I think.

The 128Gb SSD shows with 125Gb available (which is clearly a lie). I know the drive is almost full.

Also some files are locked and I can't even copy them to my external HDD. Is there a way to solve this problem ?

Have you tried holding the Left Shift key at Boot in order to pull up the Recovery Menu?
From there, you can drop to Prompt.
From the recovery menu prompt run the following:

sudo journalctl --vacuum-size 10M

sudo apt clean

sudo apt autoremove

rm -rf ~/.cache/thumbnails/*

Let me look up a guide that can help you examine Recovery Mode and its options:

Scroll down and note Recovery Mode – Clean, as well.

This is a little bit concerning. I have never seen that happen before.

I think you guys read it wrong.
It is 0 GB available out of 125GB.
Considering the SSD is overfilled, this does not surprise me.

1 Like

bonk You're right. LOL. I see it; now 0 available of (/) 125gigs.

Oh ok so it checks out with what Aravisian and others were saying about the SSD drive being full. My bad sorry for not reading correctly.

Ok I'll try the recovery mode during the boot of the OS.

Edit:
I have tried to push the left shift key as Aravisian said to go into recovery mode before the OS start during boot.
But nothing happen I see my BIOS logo with info (press F2 for setup and F7 for BBS boot menu) and after I see the Zorin logo and then the error pops up directly (missing lowerdir) and I spam the left shift key the one above left CTRL but nothing is happening.

I saw online that you need to use GRUB loader to have recovery.
So maybe my Zorin install didn't use that and now I don't have recovery ?

Edit2: I tried this to change permissions and copy over or delete files but didnt work:
[SOLVED] Permissions Change on HDD from Live CD - Old Zorin Forum archive (zoringroup.com)

1 Like

The instructions there are outdated as gksudo has been deprecated.

Instead, open a terminal and enter

sudo -i

if it asks for a password, leave it blank and hit enter
Then in terminal enter nautilus if it was Zorin Core. If it was Zorin Lite, enter thunar
This should elevate the file manager to Root.

Ok I finally managed to free some space by removing some files after copying to another drive.

I used rm -r /folder/path command to remove some files that weren't permissions protected.
Didn't think it would be so much trouble to have a filled OS drive (happened to me on Windows and the OS still boot fine).

Now the computer starts as expected before the crash.
I think what happened is I tried to unRAR 15Gb which was split into 15 parts and it was on a NTFS drive so the OS can't write on that.
So instead it wrote everything on the SSD filling it up in the process even though I didn't ask to put data there in the first place.

Thanks to @FrenchPress, @Aravisian, @337harvey which contributed to help me get out of this weird situation I was facing.
At least I learned something today :slight_smile:

4 Likes

To avoid filling up my OS disk, I have a separate 1GB SSD where I keep anything that is bulky such as music and video files. The advantage of this setup is that I can leave this 1GB SSD [edit: 1TB SSD, thanks for pointing out this mistake @gamer388 ] as is while I am reinstalling/changing my OS.

Zorin OS has recovery. If you were unable to access it, the most common cause of that is if the Grub Timeout is set too low. I use ten seconds.
In terminal, you can run

sudo nano /etc/default/grub

and check the TIMEOUT parameter.

I might suggest sticking with the default Archive Manager as it always asks the location to extract to when used.

Ok thanks for the info @Aravisian but sometimes even the default Archive Manager can't extract some RAR files.

@FrenchPress I think you meant 1TB SSD and not 1GB haaha :slight_smile:

Yeah I got a 8TB HDD hooked up to my computer so space isn't a concern. But as I said my SSD wasn't full before the bug occured so something happened and filled like hell the SSD (was like 15 or 20GB free, come on). I used the default Archive Manager but I have issues to unrar directly on NTFS drive. So I think all the data got dumped somewhere on the SSD instead of the HDD or just throwning an error and cancel.

Edit:
I have checked the value of the GRUB timeout it seems to be set at 0 (zero seconds ?). So maybe it explains why I couldn't use the recovery mode.

I have changed the timeout to 5 now (modified the line GRUB_TIMEOUT=0 to GRUB_TIMEOUT=5)

2 Likes

Thanks for pointing this out!
I fixed it.
When I first used computer, units were in the KB range. Then comes MB, followed by GB, then TB. Now you can see where my mistake coming from :wink:

That sounds like a reasonable assumption to me.

I quickly checked my own installation.
It seems that the default value is set to zero (0). I need an opinion by @Aravisian, but this value should not affect the behaviour of the recovery mode.

You would think it shouldn't.

Yet, when users with Grub Timeout=0 attempt to enter Recovery Mode, they struggle heavily. It seems there is a millisecond there where the command can pass through and only by bapping the left shift key at Warp 9.975 works.
It can be done but is a lot harder.
Holding the left shift key down works fine- except if Grub Timeout=0... Then you must bap it. Fast.
I think it is because the Timeout allows user input prior to init. Without it, init can run immediately after the splash screen, so you must be Faster than the computer to catch it.

On almost all installations I have done of Zorin OS, the timeout has always been set to Ten by default. Not sure why yours is different...

Thanks for this info. But mine is clean install of Zorin 16.
As far as I know, I did not edit grub on this system.
Puzzling :thinking:

I may have just figured it out...
I tend to install more than one Zorin. Sometimes I have a Mint partition too.

Since I make themes and such and since I test a lot of user problems from this forum, I keep "Testing" partitions where I can have at it without destroying my daily use partition.
Having several partitions with several OS installs may well be why mine defaults to ten - It changes grub when I install on another partition to allow my slow finger to select what I am booting.