Zorin-Os freezees while playing and or trying to load something in game

I just intalled Zorin-Os about 5-6 days ago and it's my first ever experience with linux so I won't know much. The problem is when I am currently playing a game. For somereason it just randomly freezes and I can't alt tab, alt + f4, and so i'm forced to hard reset. This problem has happend 4 times now in a spand of 4 days.it's only happended on the following games: Minecraft and Terraria. Other times it happens when I try to load for say loading a Mineraft World. I have aboulostly no clue what the problem is, so if any one can help that'll be greatly appreciated.

My specs are the follows:
CPU: Intel Core i3-8145U CPU @ 2.10GHz x 4
Graphics: Mesa Intel UHD Graphics 620(WHL GT2)
OS Type: 64-bit
I am also using the core version of Zorin

1 Like

Hello, it may that you are running out of RAM. It's recommending that running Zorin core with at least 8 GB for best performance and experience. Try the Lite version, some say it can run on 2GB ( I can't confirm).

I know Minecraft can be very heavy on the system. If it's possible you should put some more RAM into the computer.


Very heavy...
4gig RAM is fine for most uses. And Core will run fine on it, but Core plus Minecraft is a whole 'nother animal.


It's something I experienced on a game, too, and I uninstalled it immediately to avoid more serious issues, or even breaking the OS completely.

Knowing your computer's weakness, usually disabling complex features such as renderers, shaders and dynamic lights can give a good boost to the game's performance. Also, setting a lower graphics quality helps, if not the lowest possible. In such cases, it's better to be able to play as smoothly as possible than keeping high quality stuff enabled and dealing with these annoying troubles that waste your gaming time.


Alright, thank you guys for the tips and suggestions. I will look into doing some of the stuff you guys told me and hopefully that'll fix the problem :upside_down_face: :+1:

The one help could be a create file or swap partition.
You need a create file /etc/sysctl.d/99-swappiness.conf
Then in this file you wrote this
vm.swappiness =20
number 20 is default.
Creating this help not kill fast hard disk ssd and sometimes if you have in game a freeze.

not sure how to make a file in that file directory. I don't have permission to add a file to it.

You can used nano with root priviliges. Check a guide and tutorial, there are some explanations here on forum.

As Bourne points out, you can use Nano editor in the terminal:

sudo nano /etc/sysctl.d/99-swappiness.conf

Or, you can use the GUI text editor.
First, get sudo:

sudo -i

Launch File manager (Zorin OS Core)


If using Lite:


In nautilus File Manager, click on "Other locations" in the left pane. Then "computer" in the right pane.
That will take you to root, with permissions.
Now, navigate to /etc/sysctl.d/ folder and right click on 99-swappiness.conf and select the Text Editor (gedit) to open it.

Alright, just a question, in the terminal i did "sudo swapoff -a", then "sudo dd if=/dev/zero of=/swapfile bs=1G count=4", after that I did "sudo mkswap /swapfile", then "sudo swapon /swapfile", finally I did "grep SwapTotal /proc/meminfo". basicaly what I did was I believe add more space to the swap file folder to be 4gb sense 2gb wasen't enough. Then I did the method you mentioned. Does that affect anything, did I do something I was not supposed to do? Still trying to understand linux.

Everything you outlined looks good. I am assuming that

is referring to changing the Swappiness value to 20?

yeah, not sure how to quote something but yeah. It is referring to changeing the swappiness valie to 20. One more thing, how do I know if the swap file is on or if it's working?

sudo sysctl vm.swappiness
Here is all information.

Alright, thanks for all the help. Hopefully this is working sence my laptop hasen't crashed or frozed up eversense I did all the commands and what not. Thanks again:upside_down_face: :+1:

You can choose which solution best help you to resolve your problem.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.