Zorin OS lvm2 Install error on Gnome Boxes after Flatpack Uninstall

The Flatpack version installed correctly and I was able to make a Win 8.1 VM successfully. This is with Zorin 16.1 Core.

Once I discovered the Flatpack version did not pass through USB to the host and that the "Zorin OS" version was the fix, I uninstalled Gnome Boxes. Per this post: Gnome Boxes- No USB redirection on Flatpak - #5 which sited a successful "Zorin OS" install.

After uninstalling the Flatpack version, via "Software" uninstall, and then installing the "Zorin OS" version I got an install error:

Any idea why I'm getting this error with the Zorin OS version of Gnome Boxes??? I tried again after apt-get autoremove gnome-boxes but got the same result.

Can you please open a terminal and run

sudo apt install gnome-boxes

and relay any errors it details here?

I found the problem:

After uninstall of Gnome-boxes via "Software" (after the install with the LVM2 error) I ran the following:

sudo apt purge lvm2 && sudo apt install lvm2

per this post:

When using the "Zorin OS" version of the install, there are bad dependencies for lvm2. Purge and reinstall lvm2 per above and the "Zorin OS" version of Gnome-boxes installs correctly via "Software".

As the post points out, this may also happen on other package installs. The error is:

dpkg: error processing package lvm2 (--configure):
 installed lvm2 package post-installation script subprocess returned error status 1
1 Like