Zorin OS not recognizing attached monitors via docking station

I have installed Zorin 16 on I5 Dell Laptop connected to Targus ACP71EU docking station. Keyboard and mouse work fine but cannot get System to recognise that other monitors are attached. Have tried installing drivers for docking station.

This post contains a "Jiggle the cable" solution:

For me what worked was plugging the dock TB16 out of my computer, plugging the dock out of the power supply and put it back. Now, P3222QE monitor is detected through the dock (and the other external monitor is detected no more, they've been swapped).


Which kernel are you running currently?

uname -a

Has the Notebook and docking station compatibly worked together before this?

Does the laptop have the facility to plug a monitor directly, without the docking station? If so, try that... if it works, the problem is with the docking station.

The drivers for the Targus ACP71EU:

Possibly might find an updated driver here:

Not sure if this will help, but...
gnome-shell-extension-multi-monitors/focal,focal 19-1 all
Better support for additional monitors in GNOME shell

sudo apt install gnome-shell-extension-multi-monitors

Thanks for the reply.

uname -1 reports...
Linux paul-Latitude-3340 5.15.0-56-generic #62~20.04.1-Ubuntu SMP Tue Nov 22 21:24:20 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

Tried the wiggling cables etc not resolved

Thanks for reply Mr_Magoo,

Tried installing suggested drivers...
ERROR (code 3): Failed to build evdi/4.2.29. Consult /var/lib/dkms/evdi/4.2.29/build/make.log for details..

Unfortunately cannot get into build directory to get at log as permission denied.

This was after the following commands

sudo apt update
sudo apt install dkms
sudo apt install libdrm-dev

Hi Aravisian,

Further update, Laptop and one external monitor works by plugging monitor directly into laptop, therefore the issue does seem to be with Docking station. The docking station does work fine with both external monitors on windows (apologies if that is a dirty word lol).

I have got both monitors working in the past with Linux Mint in the past. But I now want to have Zorin working and before just installing DKMS etc seemed to work - confused atm

Well, that driver is for an older version of Linux... there's got to be a newer version available somewhere... perhaps in the Linux Mint repository?

Removed the Webpage Link as that may be perceived as Spam.

I agree that the docking Station is the likely culprit - just due to that Docking Stations are notorious.

DKMS - Dynamic Kernel Module Support - allows software to continue working in spite of a changing kernel.
Otherwise, the software needs to be coded to that specific kernel.


This may also be a clue... Rolling back your kernel to an earlier version and using DKMS may help.
Trying 5.13 kernel or 5.8 for example...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.