Zorin OS Pro - Unable to connect external monitor via HDMI

I've just installed the Zorin OS Pro on my Samsung Galaxy Book 2 (i7 1255u + Intel Iris XE) and it's not recognizing my external monitor via HDMI.

Output for xrandr:
Screen 0: minimum 16 x 16, current 1920 x 1080, maximum 32767 x 32767
XWAYLAND0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
1920x1080 59.96*+

output for lshw -c video

descrição: VGA compatible controller
produto: Intel Corporation
fabricante: Intel Corporation
ID físico: 2
informações do barramento: pci@0000:00:02.0
versão: 0c
largura: 64 bits
clock: 33MHz
capacidades: vga_controller bus_master cap_list rom
configuração: driver=i915 latency=0
recursos: memória de E/S:600-5ff memória de E/S:400-3ff irq:140 memória:6000000000-6000ffffff memória:4000000000-400fffffff porta de E/S:4000(tamanho=64) memória:c0000-dffff memória:4010000000-4016ffffff memória:4020000000-40ffffffff

I have already tried to start Ubuntu with Wayland, switch from gdm3 to Lightdm, reverse my HDMI cable, disable secure boot, update all drivers. Can someone help me with it?

Given your list of things you have tried already, I think it is unlikely to be drivers. Some motherboards restrict Additional monitors as well as power output.
Can you please check your BIOS / EFI settings on boot?
You would be looking for something like 'multi-monitor' support under Advanced > Graphics Configuration.

Actually these new samsung laptops have a really simple BIOS settings on boot, I have no option for Advanced - Graphics configuration. Is there any other to check if it's enabled or no?

You likely will have to search the web for things...
This thread may get lucky in having a user who has owned a Samsung similar model knowing what hoops they make us jump through to access our own machines these days.
And this is riding on the guess that it is a hardware setting issue. It seems likeliest to me at the moment...

You should see your HDMI port/s listed in XRANDR

Check bios settings on HDMI.
Check firmware is up to date.

So you need to see your HDMI ports in Xrandr before anything else.

You could also try opening " software & Updates "
Open the " Additional Driver's " TAB, & manually select the drivers, if listed.

First check & update firmware & check bios HDMI settings.

Don't know if this helps but i remember seeing somewhere that the Galaxy Book 2 or Galaxy Book 2 Pro (forget) needed nomodeset added to grub to work on kubuntu 22. For video. Since ubuntu 20.04 is older and that is what Zorin is based on, try that and see if it helps?

But i do know i had trouble with my flex book alpha and it was because they nerfed the port on purpose like <insert favorite sentence enhancer here> if not using a samsung android image
*excuuuuse me, they customized it and the proprietary drivers are only supplied on the flex alpha image my mistake

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.