Zorin OS refuses to suspend


I have a weird issue that I can not suspend my laptop which is running on Zorin OS 16.

I don't have any other OS on my system and also I have updated Zorin and its packages to the latest versions. My laptop has hybrid graphic cards (integrated Intel + Nvidia GTX1050) and I have shut down using the Nvidia driver by putting this command on the grub config file (/etc/default/grub):

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=0"

Zorin doesn't suspend when I hit the suspend button from the top panel or even when I enter this command on the terminal: sudo systemctl suspend
Although I turned on suspend on closing the lid, it doesn't work.

When I try to suspend, it goes on a black screen but after a couple of seconds (2 or 3s), the display turns on again and shows me the login screen.

I have installed uswsusp and this is the only way that I can suspend my system properly by using this command on the terminal: sudo s2ram.

Any suggestions?

This thread suggests the the wifi card may be causing the issue:

Do you have Atheros?

No, my WiFi card is Intel Corporation Wireless 7265.

Also, there is no such a file or directory of /usr/lib/hal/scripts/linux/hal-system-power-suspend-linux that I can put /sbin/s2ram --force in it.

In that case, perhaps it is not the wifi.

Can you try this suggestion:

If you have an SSD drive, its better to not suspend, because otherwise suspend will cause unecessary writes to the SSD and will make it fail sooner. It is better to set your system up to blank screen. Its like a screensaver of sorts. But it just gives you a black screen.

Additionally, you can setup your screenlock, enable that for security, set the time interval to lock if you wish to change it from default. You can find those settings under POWER in settings, and SCREENLOCK under PRIVACY in settings.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.