Zorin os stopped booting

I've been using for zorin now for years.
Suddenly out of nowhere this started happening.
After booting, sometimes this comes (see in screenshot). After booting again and again I do get pass it somehow.

But now

it's appearing again and again.

At the initramfs_ prompt, type exit and hit the enter key. Please relay the response the terminal gives.

Looks like a hard drive issue. You probably will need to boot from LiveUSB and run fsck.

1 Like

Hi sorry for the late reply. I had some work

Here is the output:

I tried doing fsck myself. It didn't work out

It is umount not unmount.
You can see the terminal told you that the command failed.

When you proceed to fsck anyway, you ran a very high risk of damaging the drive. Running fsck with improper mounting can cause a lot of problems.

That fsck reported a bad superblock may have been an incidental save.
You can try fsck -o b to try to access a backup copy of the superblock.

I did umount and it said it's not found.

It is found, it shows it as unmounted.
Include your partition destination in the fsck -o b command.

Like this?

Also, I saw some YouTube tutorials. They're doing "fsck" in initramfd directly

Yes, you can run fsck at the initramfs prompt since at that stage, the partition has not yet been mounted.


When a file system is mounted, the operating system assumes that it’s in a consistent state and allows read and write operations on it. However, fsck directly accesses the storage device and modifies file system structures. Therefore, running fsck on a mounted partition introduces conflicts against the operating system .

These conflicts can be so severe as to irreversibly destroy the operating system. If you try to run fsck on a mounted system, it will warn the user.

This didn't seem to work at all.

Also how can I exit from "initramfs" to boot menu?

From what I am reading in your screenshot, it looks like your drive is severely damaged. At this point, you are looking for a means to recovery data more than to save the drive.
Can you try running

smartctl -a /dev/sdb3

To run a S.M.A.R.T. test on the drive... Is your /dev/sda drive being used for a different O.S.?

Rebooting, usually.

You can type exit and follow it with tapping the enter key.

Yes /dev/sda is for windows.

Also, should I run "smartctl -a /dev/sdb3" this command in live usb?

I don't mind losing all data. Should I just reinstall zorin os? Or Ive lost the drive lol, since it's damaged


You can try reinstalling Zorin OS just for the sake of giving it the effort.
If the S.M.A.R.T. test reveals enough damaged blocks or sectors, I wouldn't... but I'm an impatient wild man...

Question: why was 'o' marked as "invalid option" in Praveen's screenshot post #8.
It is not listed as an option in the "Emergency help" list of options.
What is option 'o' ?

Thanks for pointing that out; I missed noticing that.

It's a typo error on my part.
I started to type a different set of parameters, then changed it halfway through. It is supposed to be fsck -b.

Me being in a Big Hurry... I copy and pasted from my own post trying to save time.
So I even repeated the error.
This is why having other eyes on things really helps for when I am a knucklehead.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.