Zorin OS stuck at Grub error

I'm having the same problem. It's my second attempt to use Zorin OS.

I am sorry @Aravisian I didn't respond to my last thread. I don't know about the graphic part.

For me This is what appears to me at the moment. I have no backup to go back to the old operating system and no way to go back. Until then I only have Zorin os on my 8 GB pendrive. On my SSD I am stuck in fatal GRUB failure.

Is this a fresh attempt to install Z17.1 Lite by any chance?

First. I suggest whilst running Zorin from Live USB, you copy off or backup your personal files etc.

On your Zorin USB, do you have Boot Repair Disk (or Grub Repair) as a option. If you do, try running that.

EDIT: @Aravisian Thanks for spliting 3year old thread.


From that grub prompt


Then relay what the screen prints there.


Zorin os 17. There was no "lite" when I downloaded it from the pendrive.

I'm installing again. This time I chose "Zfs". The other installation methods "none" and "lvm" gave an error in GRUB. Very suspicious, as I am a layman. Wait for more details. If it works, I'll let you know.

exit. Threw me to this screen. What do I do?

The screenshot you showed if of the BIOS Shell prompt.

BIOS shells are often unix-like and can accept familiar GnuLinux terminal commands.
However, it is not the Grub Shell prompt.

Did you enter the exit command at


1 Like

Yes. Grub redirected me to the shell after you suggested the "exit" command.

What do I do now?

This is incredible. The prompt above is asks you to run startup.nsh which is the firmware script for UEFI. This suggests a lack of a complete grub.

I recommend attempting Boot Repair:

This must be done by booting using the LiveUSB (you can use your Zorin OS installation USB stick).
The boot repair utility provides a detailed log which you can post here to examine if needed.

1 Like

What do I do now?

That This was yesterday's record when I tried LVM.

The error simply appears to be on ZorinOS's side when it tries to install without errors.

Is /dev/sda1 your EFI partition?

I don't know, but ZorinOS did it like this.

Have you tried boot repair, yet?


Ah, I see. In your BIOS settings, are you set to EFI or to MBR (Legacy)?

I managed to install Zorin @Aravisian !!!

Close this thread. I simply reset the BIOS through the BIOS software settings. Then I installed the suggested program and it fixed all the problems.



Closing thread per O.P. request.

Glad you got it installed.:grin:

1 Like