Zorin OS Stuck on Gnome Layout While Switching back and forth between PS5 and PC on HDMI

I don't know why but when I use my HDMI cord to switch between my pc and PS5, my desktop layout changes to the GNOME layout, and even if I go to appearance and then layouts and try to change the layout back to the layout I was using before, It is still stuck on the GNOME layout. I have to shut it down and restart my computer in order to see my original layout. Does anyone else have this issue?

Hello joeyjr456, welcome to the forum,

I don't have a PS5 but I do sometimes attach my minipc to a 4K screen.
I do have to use a HighSpeed HDMI cable other wise I suffer a lag.
But when moving over the normal display my layouts don't change.

Are you using the original PS5 cable, because this could be because of the refresh rate. Have you tried the "Settings for Display" and mainly the refresh rate settings or scaling?

1 Like

Hello! I am new to Zorin OS I am not sure what that means..

Try;
Menu > System Tools - Settings - Displays, there you will find the settings for Refresh Rate and Fractional Scaling.

1 Like

So I tried that and couldn't solve the issue. I did take a video of what the issue is. Here is the link: Zorin OS16 issue switching between PS5 and PC. Using HDMI. - YouTube

1 Like

I do see what you point is. But other than the FPS or Fraction Scaling, I unfortunately can't think of other solutions, this so because I don't use a playstation.

Perhaps some volunteers who do gaming or use a PS4/5 can help u resolve this issue.

I am going to take a liberty here and tag @AZorin and @zorink for this topic. This is a user configuration in a bit of an unusual case.
However, the application in question that is getting stuck is the Specific Zorin Appearance > Layouts application. This is something the ZorinGroup needs to be aware of and may be able to mitigate. At the very least, they are the most qualified to do so.

2 Likes

I had this issue back at launch of zorin 16. Same issue as you except i never used a hdmi cable. I also did a reboot to get the desktop back. Thought i made a mess of my system back then

Next time can you press alt + f2 and press the r button to see if it gets fixed without reboot.

1 Like

Huh?? but doesn't the PS4/PS5 console, require to be attached with a HDMI cable?

Are you using the pc as an hdmi passthrough switch? I'm curious of your hookup. I use the supplied switch in the monitor/tv and use the television to switch inputs.

I find your setup to be fascinating. But using an hdmi switch (external hardware) would mitigate this.

1 Like

You mean something like this? I do have it. Less than 9 Euro makes a life easier :slight_smile:

1 Like

But i believe, that you can't attach any hdmi cable you wish. PS5 requires 2.0 perhaps even 2.1, which is only available with high speed hmdi cables.

I also use to attach my mini pc with a hdmi cable to my 4K TV screen but it had much "lag" to run the screen efficient. Adjusting the settings in the Frame Rate or Scaling did not help back then. The high speed cable did the job. That's why I advised about the sort cable to use.

1 Like

PS5 comes with, and recommends any replacements to be, HDMI 2.1 cables. If you are using anything less than this you need to change it.

What i mean to say is that i got this issue without a console or hdmi cable. Maybe it is a gnome bug i dont know

1 Like

That’s exactly what I have yes!

1 Like

I think this gismo is good enough only for a low seed connection.

I used to use it when I needed another monitor for my RasPi where speed was never an issue.

Since then I've learnt how to use headless (server) installation of Debian on RasPi and I stop using it.

So I did all those and it says run command. What command do I run?

If you did ALT F2 press r and hit enter

I hit Alt+F2 and R and it pops up a window that says run command . And you type what command to enter…

The r needs to be the smaller one, not R

  1. Press Alt F2
  2. Then a prompt pops up
  3. Press r
  4. Press enter
  5. Gnome will be reloaded
1 Like