Zorin OS won't stay asleep

Hello all! I've perused as much as I can, and while the subject may be here already I cannot find it.

I have two power saving related issues. 1, my installation will not stay in suspend mode and 2, I cannot seem to enable hibernate.

I had a previous installation using Kubuntu that I was able to resolve those issues on, but the buggy nature of that OS displeased me and so I am on Zorin which, for all intents and purposes is perfect except for this.

When I click on Suspend in my menu, or cause suspend using the CLI, the system will enter that mode then IMMEDIATELY with no input from me wake. It is a clean resume as if I had intended it, no ill effects.

Hibernate is not an option, and after following many guides to enable it, I am still unable to do so. The only thing I can see is that it is due to using BTRFS for the file system. I can get as far as configuring the hibernate file, but when attempting to activate it with the system, I am given an error along the lines of, invalid options. While I can create and attribute designate the file, I cannot get the OS to actually recognize it as the hibernate file.

Any ideas? I'm at a stopping point.

I faced troubles with Suspend Option too, Here's how to enable Hibernate

These Worked for me So, :man_shrugging:

5 Likes

The Suspend also can be replaced by hibernate while closing lid or pressing the power button in Zorin Settings.

2 Likes

Hibernate Requires a swap partition not a swap file. This is easily created in disks with free space on your drive (recommend about the same size as your ram if not a little larger). Create the partition, format using the swap fs option. Add this partition to the /etc/fstab by checking the mount on boot option, after it's created, in disks (you will have to select the partition to see this and other options). Once this is done, then follow the above recommendations to enable hibernation.

Something is keeping your computer awake. Are you using any keep live software, videos, TouchPad is enabled (it doesn't take much to keep it from sleeping). Did you configure or disable the close lid option? Some things to take a look at.

A failing keyboard or TouchPad can have the same effect as touching a key or moving the mouse (reduce sensitivity a little).

1 Like

So far I've had little success creating a partition. The file option works up till the point wherein I try to initialize it using swapon, then I am greeted with the message Invalid Arguement.

As for the rest, I'm running on a desktop, and have no extra software. The system should only resume when a button is pressed, mouse or otherwise. However it immediately restarts after entering sleep.

I'll try to expand the oddly sized 1 gigabyte swap partition that was auto created during install and see if I can use that. Problem is LOCATING it in Discs, even though I can see it using the command line utilities.