Zorin OS17 - sudo apt update - 404 not found error

Hello friends,
I installed Zorin OS 17 around a week ago and it's been a very good experience so far. But recently I have faced an issue regarding "sudo apt update" and I can not install anything through terminal currently because none of the repirositories are working. I am not sure what causing this issue because I checked with Zorin OS iso file and running through USB with "Try Zorin OS" option and when I do "sudo apt update" inside the USB , it totally works.
I already checked /etc/apt/sources.list and it is exactly same as in USB but I don't know why I keep getting 404 not found error.
I spent hours since yesterday checked all the forum and also some other forums in internet but so far no luck.
I tried to activate firewall , remove all the ppas from "Other Software" but nothing worked. I also tried many different servers other than the main server but with each server I got this error. I also tried to start Zorin OS with different kernels but still I am getting the same error.
Any ideas would be appreciated :slight_smile:

This is my HW info if it will be needed for troubleshooting , I am sorry I am not so experienced in Linux ;

Sources list:


so, select every


starting repo, except the (source code) ones, and then edit your sources.list to use the Local mirror, if you live in the US it's going to be us.archive.ubuntu.com


I also choose the country I'm currently located at instead of main server and choose all ppas and tried again but again I got same error.

How can I edit my sources.list to use the local mirror?

what is your sources.list right now?

1 Like

This is the current sources list ;

WAIT A MINUTE is your architecture ARM?

1 Like

No I'm using Ryzen 7 4700U CPU that is why I don't understand why I am always getting 404 errors related to ARM.

okay... I'll need to search the Internet

1 Like

the output of your lscpu??
@Aravisian , the os detects his cpu as arm

1 Like

lscpu output;

@seckinguvenc I found the solution.
Append [arch=amd64,i386] to your mirrors in sources.list. Like this

deb [arch=amd64,i386] http://archive.ubuntu.com/ubuntu jammy universe main restricted multiverse

The thing I don't get is that I checked inside Zorin OS installation USB by "Try Zorin OS" option and ran "sudo apt update" there , it works without any issues. I am connected to same network with same settings , I even tried changing DNS in my modem settings but still same issue. It is the exact same sources.list with the default one but still it creates this error. There is some another configuration that conflicts here but I am troubleshooting for many hours still couldn't figure it out. The cases on internet are generally related to some ppas of 3rd party softwares but this 404 error comes directly from the main linux repositories which is strange.

1 Like

Ok let me try your solution @SignorCastello , give me 2 minutes

1 Like

IT WORKED! Thanks a lot my friend , I can not be thankful enough for your help :slight_smile: I was searching for the solution many hours , adding [arch=amd64,i386] into sources.list solved the issue. Thank you!


I am happy that it solved. Have a great day!

1 Like

You too my friend , thanks for your help again.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.