Zorin placed Hidden File on USB: cannot remove: locked read only all files

Tried changing the settings: says I do not have the permission to reset. I went to terminal, and cut & pasted the instructions to set myself up as Root: seemed to work at terminal...but the USB is still locked read only, and refuses to allow a change. Says "me" is the only one that can do that.
So who is "Me" that placed two hidden files (another is ".Trash-99") that also refuses to be removed? Also, one of my photos is now "damaged" and refuses to open. I found a place to run a check of USB: It says it has a damaged file...but if I run repair, it may lose data. This is my personal USB, not the USB running Zorin.
It all happened two nights ago: my screen would "suddenly go dark"....although my setting is to never close...kept going dark every 30seconds or so...hacked?

Help please. BTW: I also see conversations between two people going on in Terminal about my using it to remove bluetooth. Is the "Me?"

The file is empty...says "Zorin". Hidden.

Conversations? In terminal?

Is the Hidden file a Document-style file labeled as .hidden or a Folder /directory labeled as hidden?
A hidden file is normal - it tells the file manager to treat certain files or folders as "hidden". Hidden files and folders can easily be shown or hidden by tapping the ctrl+h keyboard shortcut.

This is also a common remainder on USB sticks.

So far, everything sounds normal... Except:

This does not sound normal. This sounds like the USB stick has corruption or damage.
USB sticks are Solid State Memory and can only handle a limited amount of re-writes. How old is the USB stick?

Hi Aravisian! Thanks for the info.

The USB is @ 5 years old. I misspoke: I said I saw someone having a conversation about my using terminal in terminal: it was in Logs. I should have included this for you to also know: the log yesterday said "USB set to Read Only" and the app that did it was Pulseaudio. So, perhaps that helps your analysis? BTW: My mom was Armenian.

The conversation was about me using terminal to block bluetooth (it worked like a charm the very first time: then it never did): when I entered the command, the terminal kept "working" and when I attempted to close it (many times now) it says "there is a process still running, and closing it will end the process." So I left it open to "think" and that was what the log conversation was about.

Also, a partition has been set in the USB...one with files and the other free space...is that normal too?

Appreciate you spending the time to assist! I am in Thailand, morning here, so I need to go now, will be back later. Thanks!

This does not sound like people communicating; rather that the terminal was being verbose - it was relaying actions to you- the User.
I would be happy to review the logs with you. You can use Spectre (Ghostbin) to relay long pastes, similar to how pastebin works.

Yes, it can be.
USB's can be tricky...
And a lot of it comes down to the manufacturer that include and then hide partitions on a drive. And some include malware.
For example, some USB sellers will take a 16gig stick, partition part of it to contain code that forces it to read as a 32gig sized stick, hide that partition, then sell it as a 32gig sized stick for a higher price. You won't discover the deception until you try to fill the drive, often way too late to do anything about it.

So I recommend sticking with known and well documented brands like Sandisk, PNY and so on. Avoid Low priced or off-brand USB sticks.

And the log stating "set it to read only" by pulseaudio is also normal?

Yes, anything written by Root will be Read Only - you can read them, but not change them. However, by elevating to Root, you should be able to access Read / Write / Execute / Delete:

sudo -i

Launch the file manager using the elevated terminal. For Core and Pro:


For Lite and Pro Lite:


Navigate to the directory in your USB drive in the Root Elevated File manager and you should have full permissions.
I do not recommend removing trash-99 directory. You can empty the directory if you want to, though.

Also, I am now getting a log stating the USB I boot Zorin from is set to read only...and problems with it too. Where is the "attach" function to send log to you? Log: "Fat-fs (sdc1): error, corrupted directory (invalid entries)...should I just toss this brand new USB and try reloading a Zorin bootable stick? Sometimes settings now will not open: "Network manager error" I don't think it was a corrupted/hacked download of Zorin: I got it in terminal from linux 22.4 OS. I can't reset the read only...as I am locked out. I thought the User had admin privileges, but it does not recognize me at all. Even when I open an admin account with PW.

Did: the settings won't change. After I close window, they reset back to read only.

"zorin@zorin:~$ sudo-i
sudo-i: command not found"

KINGSTON is the brand.

I did exactly that, went to the directory, set myself as root: nothing happened.

You need a space. sudo space -i. Just like this:

sudo -i

Kingston is reliable.

I'll try your code in terminal later: I found my missing files in "Home/Cache" saved from yesterday...when I was hacked. I could not understand where files and photos I downloaded to this USB stick was going: to this cache, now all in thumbnails: unusable. Over 3000 files...apparently Zorin redirected it to my Boot file...now corrupted too.

And while I was trying to figure this out, all of a sudden the KINGSTON unlocked...

Zorin is not a secure OS at all...even if you just boot it up every time: it saves your stuff without permission.

And what is the problem with terminal? How can I enter something, get no reply...but it never closes running an application?

Thanks, I will let you know later if the code you sent worked.

Do you have a Windows system to try the USB on and see if Windows thinks the file is corrupt? I have had some issues with exFAT on USB thumb drives not playing well on Linux. Maybe it is my drives but...when I formatted the USB to NTFS it worked on both Zorin and Windows 7.

Of course, it could also be you have a corrupted file. :slight_smile:

@Wally , earlier, you stated that two people were having a conversation about removing an application in your terminal.
However, the x-term is not a chat application. It does not work that way.
Next, you state that you were hacked.

I can certainly understand how you might interpret what you see.
This direction is unproductive though and while we will be happy to help you to understand the terminal and to troubleshoot USB issues...
It is essential that we stay on track, here.
Please set aside speculation and supposition and relay details or screenshots of what you see on your screen.

Was working fine until yesterday, when all of a sudden my screen started going dark...I'd touch the pad, it would reopen, then in 30 seconds or so go dark again. (Settings are "never close") Long story short: I have been suffering "missing images/files" lately...enough to make one think they are losing it. I found them a few minutes ago: In "Home/Cache" under a numbered file...I opened it and there were all those missing files (3,327)...apparently saved to my Boot stick. (KINSTON USB was not installed)

I didn't put them there and funny thing: Only that file was not locked.

Not random: all on the exact same subject I am researching. So, I grabbed another USB, ready to transfer these mostly useless thumbnails ("Large") when LO and BEHOLD Zorin decided it a good time to actually perform the "write though" of my cache wiping them all gone permanently. So as I was typing? I was being monitored here...then attacked while trying to transfer those files.

Zorin must go. Apparently there is a flaw allowing "someone" to enter my files and do as they please by rerouting files from one USB to my bootable one...that is why I am now also seeing the log informing me that USB is now corrupted.

I should mention: As this boots up from USB, (not installed), some code in brackets shows up before you chose "Try" or "Install" Zorin......I noticed a few days ago "extra brackets and code" on that...now gone. Someone attempting to find a way into a bootable uninstalled Zorin USB...successfully. Zorin is flawed.

Thanks for all you guys assisting me, much appreciated.

In Directory, I did see a setting with "Windows" clicked but when I clicked the Linux tab? Said I would lose all data by doing so. This is a Dell that came loaded with Linux. Was working fine before...not sure if that setting was messed with too, or not.

Giving up fellows. Tired of fighting this stuff. BTW: When I used 22.04 I got a very strange message in Logs: YAMA: "Subject becoming aware."
YAMA: "Subject becoming defensive"

Any of you ever see "YAMA" listed in Logs with all the other item?