Zorin Pro 16 won't boot up to login screen after installation in Macboook Pro 2009


I have an old Macbook Pro 2009(system requirement all met) and would like to switch to Zorin Pro 16 for the first time. I follow the entire installation procedure post on the website(I chose the erase everything option since i can't upload the new IOS anymore). No problem running through the USB flash, checking process and installation. After the installation is completed, it restarts and request to remove the USB that was plugged in. Then i remove and press enter and the computer restarts. It starts with the Zorin logo and the Letter Zorin after. Then it stucks in a blue screen and won't move on to the log in screen. I tried reinstall twice the system and still the same result. What should I do now? Did I miss any hidden steps or I need to change some setting in bios or elsewhere in the computer? Please advise. Thanks a lot.

Hi and welcome to the forum :slight_smile:

I found some threads about Macbook in the forum

Also I found this external site:

If we ever unable to help you, you can ask a direct help from Zorin developers since Pro version comes with an installation help service. The best way to contact them is replying the email you have received when you made a purchase.


Thank you for the links. I try the threads but seems no one has this issue. I had sent a email to the support team but haven't hear back from them yet.

The ZorinGroup consists of two people; Artyom and Kyrill Zorin. Zorin OS 16 (possibly due to Win 11 restrictions) was a Landslide release.

You will hear back from them... But it may take some time.

In the meantime, have you tried using rEFInd? Many Macbook users use it to install Zorin or other Linux Distros onto Macbooks.

1 Like

Thank you for the heads up. No. I haven't try that yet. I'm currently trying other methods that I found online is similar to my issue. I will try eEFInd method after. It looks like need some time to read and learn how to use it. Many thanks.

1 Like

I try the method on the site i posted below and finally get to the desktop but i have to choose the recovery mode and select normal boot up in order to boot to the login window. I still can't get to the desktop like normal boot up at the beginning. I think I have to change the boot up methods in my Macbook pro system. Here is the link in case anyone else has the same issue like mine:

I will post the method to make it boot up normally without enter the recovery mode later if i can figure that out. Thanks all.

I ran into a similar issue on an older Macbook. Then I tried installing Zorin 15 Lite with the XFCE window manager and it worked fine. It might be a Gnome issue.

Not an ideal solution but it lets you run Zorin on a Macbook


Hi Aravisian,

I read your response to someone's safe graphics installation thread question. Will the legacy and EFI be my problem? Here is how my log in routine is now:
I power on and get to this screen, then I choose the second advance option (if i choose first option Zorin which will end up in the blue blank screen that won't show login screen i initially posted)

After that, I will see 4 options(2 genric and 2 recovery mode) but I will choose the recovery mode (the genric one will lead me to the blank blue screen again)

By choose the second option recovery mode will lead me to the following screen. Then i choose resume normal boot and it will lead me to the login screen and then desktop no issues or crash or black screen. Is there any ways you know that i can boot normally instead going through all these steps and boot up? Or should I try to install the safe graphics mode? Please advise. Thanks a lot.

Can you follow your routine to boot, then once in the Desktop, open terminal and run

sudo nano /etc/default/grub

Find this line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and change it to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Once done, hit ctrl+x to exit, the y key to say yes to save, then the enter key to save current configuration.
The terminal will revert to normal.
Now run in terminal

sudo update-grub

Try a couple test reboots - Hard Reset.


This is a grub issue......Darn it you beat me to it! Love the help here is on top of it. :grinning_face_with_smiling_eyes:

I was typing literally when your post came. Ha


Wait for the user to reply with:

It didn't work


Hi Aravisian.

Love you to the death. It work perfectly and boot up right away. No issues.lol


Sorry, Bubby. Maybe next time you get Top Billing. :grin:


Am I the fewer person that lucky and get fix the first try? Why you want to see me fail? lol

1 Like

One of the most dreaded comments I hear too often across the forums is
"it didn't work."


Hey the outcome was the important part and I merely get AMAZED at the speed of assistance provided on this forum!

AND FOR FREE!! Where else can you do that? Certainly not at M$!

@Slacker We never like Failure that isn't what was meant by the comment fellow Zorin user.

1 Like

@Aravisian did that to me in more than one occasion :frowning:
Somewhat it is not fare.

You and I have this disadvantage of not being native speakers of English. We demand Golf Handicap!


Totally agree. Never been to any forum like this one before. Highly appreciated all of you guys' assistance. Four people response within a day-"God Speed". By the way, I'm a tech noob. Will that make you guys feel better than the language barrier? I'm pretty sure you guys will see my post again future in here. Take care all. lol


< Forum hog...


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.