Zorin runs lightdm despite being set to gdm3

I was trying to install the amdgpu-pro driver with OpenCL (which doesn't work btw) to run Davinci Resolve via this: How to install DaVinci Resolve on Ubuntu with AMD GPUs - CIALU.NET
At some point I must have uninstalled the driver, unsuccessfully installed it and then rebooted. To fix not having any graphics driver, I installed it in recovery mode via this: Activate AMD Radeon Graphics Card - Zorin Help
So as far as I'm aware, I'm not running the official driver anymore. This was working anyway at first, but everytime I opened Discord, I would be sent to the login screen (no entire restart though it seems). After a few times this resolved, but the task bar was now at the top and all shortcuts on the desktop gone (maybe it switched desktops automatically). I tried to fix this with "sudo apt install --reinstall zorin-os-lite-desktop", was asked to select the display manager and took lightdm, not knowing gpm3 is the default. I tried to revert this with "sudo dpkg-reconfigure gpm3" and the login screen now is in gpm3, but when I log in on the zorin os lite desktop (which I was using and is probably the default), it will launch in lightdm.
Running "sudo apt install --reinstall zorin-os-lite-desktop" will not ask me again to select the display manager, looking for updates doesn't resolve anything, and fixing packages in recovery mode I also already tried.
Any way I get to my old state without a complete reinstall? And yes, I know lightdm is apparently better than gpm3, I'm just too lazy to get used to something new.
Also I don't have much clue about zorin or gnu/linux in general.

LightDM is the default for Zorin OS Lite. It is what came with Zorin OS Lite when you installed it and what you have been using from that point.
I also recommend continuing to use LightDM on Zorin OS Lite as LightDM meshes better as a Display Manager with XFCE than GDM3 does.

GDM3 is the default on Zorin OS Core (Gnome).

As said, I don't have a clue. I actually use Zorin OS Core. Starting with "Zorin Desktop" gives me the missing shortcuts and wrong task bar, so I'd still like to fix that.
Also, I'm going to very politely ignore your recommendation. If Zorin 17 only has lightdm, I will have no problem using that. Pretty sure I even used it with Zorin 15. But right now, I don't have to use it.

You can see why I would be confused. Your profile lists your Zorin OS Edition as "Lite" and your O.P. said you

Let's get this fixed:
The command for Zorin OS Core is apt install zorin-os-desktop. First, we will remove the Lite D.E.

sudo apt remove --purge zorin-os-lite-desktop

Do Not Log Out or Reboot - Once that has completed, then run

sudo apt install --reinstall zorin-os-desktop

to reinstall GDM3 and the Zorin Gnome Desktop (Which should also resolve the issue of the panel (taskbar) and everything else seeming different to you.

And please also update your User Profile to say "Zorin Core" :wink:

It is confusing at first, but once familiar, it will seem quite easy.
Zorin OS comes in multiple editions and they can have Different Desktop Environments.
Core uses the Gnome Desktop Environment (With GDM3 as default).
Lite uses the XFCE Desktop Environment (With LightDM as default).

There is also Zorin Education, which comes wit Education Core or Education Lite
and Zorin OS Pro (Gnome) and Zorin OS Pro Lite (XFCE).

2 Likes

Sorry for confusing you. When creating this post (and also this account), I was aware of different editions existing, but had long forgotten which one I was using, so I just assumed the commands I was finding would surely be for my edition. So while I can't remember putting Lite in my profile, I probably just did.
Nevertheless, after running your commands, gpm3 launches correctly on all desktops (except for ths first one, which is to be expected), so thanks for that. The "different" stuff is still there though.

You installed another Desktop environment. It brought some friends.

I think the easiest way you can sort this out would be to install Synaptic Package Manager:

sudo apt install synaptic

Launch and then use the Search Button on the upper toolbar
Search xfce

Select any of the Installed XFCE packages for complete removal.
Once all are selected, click the apply button.

Reboot and test...

It says "Core" now. If you did not change it, then it means I made an error.
I remember seeing it... But I also remember the scene in E.T. when rescuers needed to use the jaws-of-life to extract Elliot from the Sterile plastic tubes.
I can picture the scene. Only problem is... it never happened.
Brains are funny animals.

So, I may have also confused your profile with another user I had checked, too.

2 Likes

Tried it and nothing changed. Note that this problem first occurred before I accidentally installed lite packages.
Don't worry, I changed it to Core and just didn't bother telling. I also now remember how I selected Lite without putting much thought into it, when I created this account.
Yes, brains are faulty indeed :smiley:

Are you referring to GDM3?

Can you try following the prompts that spaawn from

sudo dpkg-reconfigure gdm3

I was referring to this.

Did not change anything. Pretty sure I did this earlier as well.

I had thought this may be the changed Desktop.

This sounds like a total crash.

And this has had no effect on GDM3. Hmmm.

@Sonathan , given that you were installing unknown packages on the system, including a separate desktop environment, it may be much better to consider this a Learning Experience than to try to suss out and untangle what has been done.
When I first used Zorin OS, I did the same thing. I did it a lot, actually. Still do sometimes...
Anyway, with all those installations and removals, backtracking it all may be more damaging than it is worth.

I would highly recommend a reinstall with a fresh start.

Yeah, all Desktops look like this now (if you can say that).

Ok, will do this weekend. If that doesn't fix it, I'll be in touch. Thanks for now.
Had I given up after reading this (AMD Radeon OpenCL), I wouldn't have to reinstall now. Sadly, I was too motivated that I could get it to work.

I'll mark your second message as solution, since this was originally about me installing lightdm on Core.

We must be connected at the hip ..... if I don't have to format and reinstall Zorin 16 Pro from my Rescuezilla backup every 10 days or so I feel I have been cheated out of one of life's little pleasures .... :grinning:

You remind me...
I still need to make a back up. Because I still haven't.

1 Like

Yup thank god I made one 5-6 days ago so I had most of my up dated apps and files ..... gotta do another one very soon after all the work you went through to straighten my last screw-up with total destruction of Nautilus ....

I had deleted it a long time ago like more than 6 months BUT I hadn't used the .... --purge .... command just did that day before yesterday ... that was the straw .....

Quick addendum: the "weird" Desktop was just the fourth Layout in Zorin Appearance, but I forgot that ZA existed. At least I have unlimited tries at installing Resolve now.

1 Like

I just did a complete backup last night while watching TV .... works out good that way as I work on my laptop from a small folding table in the sala (living room) right beside my recliner .... easy to keep an eye on while backing up ....