Zorin store doesn't have internet access

Hey there! For a few days now I've been unable to use Zorin's software store because it doesn't seem to have internet access at all.

  • When clicking on apps on the front page or searching for an app only the loading circle appears.
  • In the updates tab it just says "Looking for updates, this might take a while..."

My internet connection isn't the problem because I can

  • surf the internet with different browsers
  • send e-mails from Evolution
  • install Atom packages
  • apt-get upgrade
  • wget zorin.com

When going to the "Info" section in the system's settings and clicking on "Software updates" it just says: "The apps on your device are up-to-date". (I don't know whether the system was actually able to check for updates or whether it didn't find any due to no internet connection.)

Here's what I already tried (without success):

  • restart the computer
  • disable WiFi and re-connect
  • connect to different WiFi

I'm using Zorin OS 16 Core with Linux Kernel 5.13.0-28-generic.

What might be the reason? How to fix this?

Thank you!

Open software and updates and see if the Zorin and Ubuntu software sources are enabled. If you can update via the terminal without error there is no problem with the update sources. For an alternative and more detailed package manager you can try synaptic for now.

sudo apt install synaptic

Also check whilst there that software and updates are pointing to "Main Server" not a regional server.

You may also kill software store gnome-software and remove the cache files and config files for it. Then reinitialize gnome-software.

killall gnome-software

rm -rf ~/.cache/gnome-software


sudo apt install --reinstall gnome-software

Thanks, this seems to have solved the issue. I also switched to the "Main Server" instead of the regional one (in my case German).

What happened? I've been waiting for 1 hour, updates in the software store don't run and install new applications also don't run. My internet is smooth and storage is more than enough.

Try removing the ~/.cache/gnome-software directory, then

sudo apt install --reinstall gnome-software

log out and in and test.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.