Zorin17 - can't print & other issues after latest update today

Hi , recently upgraded 16.3 pro to 17pro , I have an outstanding query with Pro helpdesk (no response yet) about inability to preview videos with spacebar (Totem not working) , if anyone can help . but I can live with that .

But Today I was printing some documents & it suddenly stopped printing after some update I agreed to, Print jobs in queue but not sending to printer,

Also Im impaired vision & after rebooting Laptop the fonts got a lot smaller, I no longer have acessibility option in settings, Infact settings are not acessible at all in the main menu or right click on desktop. This is so frustrating .

If its not corrected overnight by another update or rollback I'll need to ask how to rollback to 16.3 pro from 17 as this is unworkable .

Thanks in Advance .. Don

link to screenshot of system specs

Can you please post the terminal output of

sudo apt update

Hi, don't know if it is relevant or otherwise, but Zorin 17 now boots into a DE that uses Wayland, not x.org. Have you tried booting into x.org? At login, select your username and a cog appears bottom right - click that and choose the bottom option below Zorin (default) to Zorin on xorg.

Another update came through thismorning, my printing issues resolved, but had to chose a new added printer option . My screen resolution is back but universal acessibility is still gone.

FWIW here is the terminal output, but its after todays update, yesterdays caused the issues, thanks.

don@don-Latitude-5414:~$ sudo apt update
[sudo] password for don:
Hit:1 AARNet Mirror jammy InRelease
Hit:2 AARNet Mirror jammy-updates InRelease
Hit:3 AARNet Mirror jammy-backports InRelease
Hit:4 Index of /ubuntu jammy-security InRelease
Hit:5 Index of /zorinos/apps/ubuntu jammy InRelease
Hit:6 Index of /stable/ jammy InRelease
Hit:7 Index of /zorinos/drivers/ubuntu jammy InRelease
Hit:8 Index of /patches/ jammy InRelease
Hit:9 Index of /zorinos/patches/ubuntu jammy InRelease
Hit:10 Index of /apps/ jammy InRelease
Hit:11 Index of /drivers/ jammy InRelease
Hit:12 Index of /zorinos/stable/ubuntu jammy InRelease
Hit:13 Zorin OS Pro - Zorin OS jammy InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
24 packages can be upgraded. Run 'apt list --upgradable' to see them.
don@don-Latitude-5414:~$ ^C

Thanks, I tried xorg and it does not help, Overnights update has solved most of the issues , so I guess the switch to Wayland, whatever that is, caused my issues.

Wayland is the new desktop compositor (graphics environment), more secure than x.org. I did not realise that x.org was so insecure as it can be used to log keystrokes.

Also, in terms of Software Updater have you got it set to Main Server?

Thanks, No it was on Australian server, Now on Main server , Will see if that helps.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.