ZorinOS 16 Installer stuck on Updates Windows

Hello, I'm trying to install ZorinOS 16 Core but unfortunately it gets stuck on "Updates and Software" and does not go past this screen. I can't install it.

Can you please try running the installer with the option to connect to the net set to "Off". Uncheck the box for "Update as you install"...
Once installed, reboot and log in to the desktop, then connect to the net and run the updater.

1 Like

I've tried this, it doesn't work, tried the exact same on a laptop, it worked. The only different thing was the Grub Boot Loader.

Are you installing dual boot with Windows or installing Over a Windows partition?
There may be an NTFS corruption on a partition - if you are installing Over that partition, then deleting the partition in the partition manager, then re-adding the freespace as ext4 FS should do the trick.

How do I check to see if its corrupt?

Using Windows, you would run the chkdsk utility or on Linux, the fsck utility.
If you have no operational O.S., the motherboard has the S.M.A.R.T. disk integrity tool.

If grub is different, it means you have to play on your pc with the UEFI (or Legacy boot) option.

Did you shrink your C:/ drive/partition to make space for Zorin beforehand?

@Cyricli Was that important question answered?