ZorinOS 17 WiFi Adapter keeps disappearing after random time, even when actively used

Hi Forums,
I have a WiFi issue like some people reported, but so far, none of the fixes worked.

I run a Lenovo E15 G4 with Zorin17 only on it, all updated.

The symptom:
After some time the WiFi-Adapter disappears and only a reboot will bring it back. It is independent on which WiFi I am connected to and the timeframe does not seem to follow anything regular. I have set wifi power saving to =2, but it also happens while I'm using the computer actively.

Kernel version is 6.5.0-28-generic

lshw gives me
*-network
Beschreibung: Kabellose Verbindung
Produkt: Realtek Semiconductor Co., Ltd.
Hersteller: Realtek Semiconductor Co., Ltd.
Physische ID: 0
Bus-Informationen: pci@0000:03:00.0
Logischer Name: wlp3s0
Version: 00
Seriennummer: e0:0a:f6:7f:b3:eb
Breite: 64 bits
Takt: 33MHz
Fähigkeiten: bus_master cap_list ethernet physical wireless
Konfiguration: broadcast=yes driver=rtw89_8852be driverversion=6.5.0-28-generic firmware=N/A ip=192.168.69.253 latency=0 link=yes multicast=yes wireless=IEEE 802.11
Ressourcen: irq:74 ioport:2000(Größe=256) memory:fd400000-fd4fffff

Any ideas on the case? Thank you!