ZorinOS16 is switching off Bluetooth and USB-Ports

Hello from germany,

I'm using a Thinkpad E595 (Ryzen 5 3500, VEGA, 32GB RAM, NVME) with ZorinOS 16.

When using battery mode at startup, ZOS is switching off Bluetooth and USB Ports after about 60 seconds (USB first, then after another 15 s BT) and doesn't turn it on when switching back to powered mode.. I even can't switch it on manually...

Settings in „ENERGY“ don‘t work, System doesn't remember the settings. BT-Off-Switch is "always on" when starting the system.

And still no USB-Port is working in battery mode after 60 seconds.

Double-checked litteraly all BIOS-Settings, but no chance to get the USB-Ports working...

This didn't happen in Win10 or LinuxMint which i was using before ZOS16. Everything works fine when using powered mode right from the start.

Any suggestions to solve this problem?

Regards Juergen

P.S.: Crosspost from r/zorinos subreddit

Powersave is disabling them.
Try disabling the powersave.

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Change the value to 2:

wifi.powersave = 2

ctrl+x to exit, then the y key to say Yes to save, then the enter key to exit saved configuration.

Sorry for the delayed answer...
Solution didn't work, both devices are still disabled in battery mode and will not come alive when connecting to power.

ifconfig says:
iwconfig wlp4s0 | grep "Power Management"
Power Management:off

regards Juergen

Do you have the following file on your computer?
/etc/laptop-mode/conf.d/usb-autosuspend.conf

If you do, let's edit:

sudo nano /etc/laptop-mode/conf.d/usb-autosuspend.conf

Set to CONTROL_USB_AUTOSUSPEND="0"

Nope, neither the directory nor the file!
I just installed ZorinOS 16 LITE on a very old HP ProBok Laptop. Same here: no directory/file.
BUT: USB/BT are still working in battery mode on HP. The behaviour ist as I expectet: start in whatever mode you want, USB and BT aren't switch off by the OS.

If this is the case, I wonder if gnome-power-manager is cutting off the services...
Under Gnome-control-center > Power > Power saving - is this set to "never"?

I'll try to translate my german settings into english...
Attached you will find a screenhot of my ZOS Core-settings (these re the only settings I found....)

Both, WLAN and BT-Settings are switched off. Description says: WALN/BT can be switched off to save power.
IMHO it CAN be switched off for power saving purposes, it is not a MUST.
I toggled both switches to off --> System is going into airplane mode. This ist not my suggested behavour. I like to keep both network-devices always on whether in powered or battery mode.

Just installed ZOS16 Core on my old HP ProBook, just to ensure, that it's not a "feature" of my Thinkpad. Same behaviour as described above.

IMO this is a bug. When a toggle switch is "off", the behavour should be e.g. "WLAN ist not switched off" to save power. Vice versea: if Toggle switch is "on", system can switch off power of the device if needed.
It makes no sense to switch to airplane mode when both switches are off.

Maybe I have a wrong understanding of the switches....

Regards Juergen

No ideas???

Gnomes Airplane mode has always been a major headache:

Video: