My installation of ZOS 17 so far has been flawless. I have not had any issues running the OS, getting updates, or installing software. I run it on an external SSD like I do with LMDE 6 with no problems. Kudos to the Zorin team.

However, on ZOS 16.3 and also for LMDE 6, sudo grub update would execute os-prober and update the GRUB accordingly. I don't need it now but I do find it convenient on my other SSD with LMDE 6, whereby Windows 11 or LMDE 6 are shown in the boot menu. I had that option OS 16.3 too. In fact, I had about 5 distributions running on one SSD with Zorin 16.3 as the lead distribution and was able to boot directly into Windows 11, Kubuntu, LMDE 6, and Tuxedo OS. Windows 11 has always been on the main NVme separate from Linux on another SSD.

When ZOS 17 came out, I decided to do a fresh install on a dedicated SSD. Despite doing a grub-update, it won't find Windows 11. The grub-update does NOT execute os-prober to find other operating systems.

Just wondering if anyone knows a fix to this? Maybe I did something wrong during the installation? I have installed dozens of distributions over the last 4-5 years this has me somewhat stumped but not a big deal. I do remember some issue with the grub customizer not being available in the repository for the 22.04 LTS but I am not trying to use that.

Thanks for any assistance. :v:

If you want to disable OS Prober:

Edit /etc/default/grub to add:

# Prevent 'device-mapper: reload ioctl on osprober-linux-sda4 failed: Device or resource busy Command failed.' on sudo update-grub.

Then run sudo update-grub again.

Note that it will no longer try to find other OSs, so you'll have to manually set up your Grub menu.

I uninstalled OS Prober, since I only run Zorin OS.

OS Prober was disabled in 22.04 due to security reasons, so if you want it to work, you can change the above line to:

If you don't make a lot of changes to your OS mix, and you want better security, I'd recommend disabling OS Prober and manually setting up the Grub menu.

1 Like

To tack onto Magoo's reply above:


Will allow OS-Prober to run.

1 Like

Thanks. Issue resolved! :+1:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.