100kbps in Zorin os only

I'm noticing that my net speed limit is set to 100kbps in my zorin os but in windows it's more than 100kbps.

Please do an OOKLA Speed Test online, post the results from that please.


Your Tech Support Guru

of windows

Our cool zorin os @startreker

Are you Indian ?

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Change the value from 3 to 2.
ctrl+x to exit, then y key to say yes to save, then enter key.
Reboot and test.

There is a known bug in the backport of iwlwifi dkms and removing that package may help some users:
sudo apt remove backport-iwlwifi-dkms

it's already 2 what if I set it to 1

This is usually happens when I use my wifi either directly from wifi or from bluetooth ethernet but when I use Usb ethernet the speed is same as in windows

1 Like

3 is enabled. 2 is disabled. 1 is Ignore.

This actually still makes me think it is powersave. Have you run:

sudo systemctl restart NetworkManager

after editing the file?

I agree, those speeds prove something is not right on Linux on your computer. The only commands I know how to disable power management are these...

CTRL ALT T to enter terminal.

xset -dpms

I hope this resolves the issue. Be sure to restart after this as well. Hope it works!

Hmm, I actually done something which I think I shouldn't had cause it makes it worse.
Since my window uses realtek drivers so I Install it in linux also but now it worse cause now it won't even connect to network.......

Is there a way to rollback to previous drivers

You installed drivers, did you restart after installing them?

Yeah, I thought realtek would be perfe ct but unfortunately it's not and I wanna go back to previous driver.

Please post the output of

sudo lshw -c network

It says "not found" I thought it's Ishw nvm

description: Wireless interface
product: RTL8821AE 802.11ac PCIe Wireless Network Adapter
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:01:00.0
logical name: wlp1s0
version: 00
serial: c8:3d:d4:a0:24:e7
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rtl8821ae driverversion=5.11.0-38-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
resources: irq:36 ioport:2000(size=256) memory:e8c00000-e8c03fff
description: Ethernet interface
product: RTL810xE PCI Express Fast Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: enp2s0
version: 07
serial: 54:e1:ad:04:33:f9
capacity: 100Mbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.11.0-38-generic firmware=rtl8106e-1_0.0.1 06/29/12 latency=0 link=no multicast=yes port=twisted pair
resources: irq:28 ioport:1000(size=256) memory:e8b00000-e8b00fff memory:e8800000-e8803fff
description: Ethernet interface
physical id: 1
bus info: usb@2:2
logical name: usb0
serial: 12:8f:6b:69:bf:66
capabilities: ethernet physical
configuration: broadcast=yes driver=rndis_host driverversion=5.11.0-38-generic firmware=RNDIS device ip= link=yes multicast=yes

1 Like

Can you please try:

sudo apt update && sudo apt install git dkms

git clone https://github.com/lwfinger/rtw88.git

sudo dkms add ./rtw88

sudo dkms install rtlwifi-new/0.6

says already exist
what should I do ? the wifi now doesn't even work and doesn't even connect to any wifi and bluetooth pairing also failing again and again the only option I have is to use usb ethernet.
can this be resolved after update ?

Can you check the Blacklist file and see if your module is on there:

What does:

sudo modprobe -r 8821AE

sudo modprobe 8821AE


Hmmm... so the current kernel version is not supporting it. Do you have dkms installed?

How can I check if it's installed